WordPress.org

Ready to get started?Download WordPress

Forums

WordPress slider plugin - Featured Articles Lite
[resolved] [Plugin: Featured Articles Lite] Strange things after update (2.4.9) (14 posts)

  1. claudia.komesu
    Member
    Posted 2 years ago #

    Dear Featured Articles,

    I've just updated to 2.4.9 and had some problems. FA plugin is causing misconfiguration in my homepage layout (for example, it makes the home page ignore break lines), and it causes the showing of strange texts like "[raw] and [/raw]" around my Flickr widget. When I remove the FA shortcode, everything come back to the right layout and no strange text apppears.

    FA is a great plugin, I would like to keep it in my home.

    Would you have any idea why is this happening?
    I use WP 3.4 and Striking theme.

    many thanks and kind regards,
    Claudia

    http://wordpress.org/extend/plugins/featured-articles-lite/

  2. constantin.boiangiu
    Member
    Plugin Author

    Posted 2 years ago #

    Can you please post a link to your installation? Just tested shortcodes and everything seems to be working fine. Also, with this update, there were no changes made to shortcodes except for the the button on WP editor.

  3. claudia.komesu
    Member
    Posted 2 years ago #

    Hi Constantin,

    it's
    http://virtude-ag.com/

    the text above and below the FA slideshow seems right because I've placed a framed box around it, or it would be displayed with no line break, touching the slideshow.

    The "[raw]" is around Flickr title, on the end of right column.

    It's very strange cause, if I remove the FA shortcode, everything is right again.

    many thanks and kind regards,
    Claudia

  4. constantin.boiangiu
    Member
    Plugin Author

    Posted 2 years ago #

    Hello Claudia,

    To put some space between Featured Articles and the text above and below the slideshow, you can do one of the two:

    1. Edit stylesheet file for theme classic; on line 4 you'll see this: .FA_overall_container_classic. Change margin from margin:0px auto to margin: 10px auto

    2. OR in your WordPress theme stylesheet, create a new style for a wrapping element of slideshows, let's say

    div.FA_spacer{ margin:10px 0px; }

    Next, whenever you want to put a slideshow into a post, wrap the shortcode like this

    <div class="FA_spacer">[FA_lite id="SOME ID"]</div>

    You might want to use the HTML editor instead of the visual one when doing this.

    About the raw shortcode, that appears on your page only when you put FA shortcode on your home page? FA doesn't have such shortcode implemented in it so I really don't know what to say or why that happens.

  5. claudia.komesu
    Member
    Posted 2 years ago #

    Hi Constantin,

    Unfortunatelly, it seems it's some conflict with the update of FA, because the problems appeared after I updated to 2.4.9, and they don't show if I remove FA shortcode. Yes, the "[raw]" just appears if the FA shortcode is in the page. I wish I could use the previous version, but I know it's a wrong practice.

    Probably it's some of that issues we'll never solve. Thanks for trying to solve it, but you don't have to worry anymore, I know there's nothing you can do, I'll decide later what to do.

    kind regards,
    Claudia

  6. constantin.boiangiu
    Member
    Plugin Author

    Posted 2 years ago #

    Actually, there could be something else that I could do but for that I would need access to your server to understand why this is happening and under what conditions.
    Please contact me here: http://www.codeflavors.com/contact/ to comunicate privately if you want to let me try to debug this issue.

  7. drezac
    Member
    Posted 1 year ago #

    We are also having a similar problem.

    Since updating to the latest version of WordPress, since we are a podcasting network, before, FA Lite used to just take the text from the podcast/blog post. Now, for a plain blog post (no podpress audio) if there is a podcast at the top of our feed, FA Lite is using the Podpress code as its text.

    See: http://edreach.us/wp-content/uploads/2012/08/Screen-shot-2012-08-11-at-4.35.09-PM.png

    To remedy this, we are having to put in Post Excerpts for every post, and it's getting really taxing for contributors.

    Check out the front page at http://edreach.us

    DR

  8. constantin.boiangiu
    Member
    Plugin Author

    Posted 1 year ago #

    I assume you're using this plugin for podcasts: http://wordpress.org/extend/plugins/podpress/

    Can you please confirm?

  9. drezac
    Member
    Posted 1 year ago #

    Yup. Pod press.

    DR

  10. drezac
    Member
    Posted 1 year ago #

    Okay- I don't want to keep this up for too long, but look at the most recent post on the FA Lite Slider that's on the front page.

    http://edreach.us/

    DR

  11. constantin.boiangiu
    Member
    Plugin Author

    Posted 1 year ago #

    Version 2.4.9.2 (will be released in a few hours) will solve this problem.

    podPress puts a filter on the_content that injects the code for the player. Featured Articles runs all the_content filters before removing any undesired HTML tags (specified in slideshow settings) and was leaving the podPress player text into the slide.

    The solution implemented to prevent this from happening is to run only the default WordPress filters: wptexturize, convert_smilies, convert_chars, wpautop and shortcode_unautop.

  12. drezac
    Member
    Posted 1 year ago #

    Okay-

    So I ran the update. And yes, I no longer see Podpress code for the player. However, now the slider is pulling in images from the articles right into the slider.

    Check here, here, and here.

    Thoughts? For the moment, I added "allow" and <p> tags. It doesn't bring in the text at all. Is there tag that will just allow the text? In the WP editor the text is not tagged, mostly.

  13. constantin.boiangiu
    Member
    Plugin Author

    Posted 1 year ago #

    Just tested, this shouldn't happen. Please check that:

    1. Option Allow these HTML tags doesn't contain <img>
    2. Option Allow all tags is unchecked.

  14. drezac
    Member
    Posted 1 year ago #

    These are my current settings:
    http://edreach.us/wp-content/uploads/2012/09/Screen-shot-2012-09-07-at-12.32.22-PM.png

    I have removed text at the moment, so this problem doesn't happen. When word press made their last update, did they do something to make <p> tags behave differently?

    DREZAC

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic