WordPress.org

Ready to get started?Download WordPress

Forums

WordPress slider plugin - Featured Articles Lite
[Plugin: Featured Articles Lite] shortcode not working (6 posts)

  1. ghostyzx
    Member
    Posted 2 years ago #

    The shortcode is not working, the required css and js files are not included in the final page.

    http://wordpress.org/extend/plugins/featured-articles-lite/

  2. constantin.boiangiu
    Member
    Plugin Author

    Posted 2 years ago #

    Check your WP theme footer.php for wp_footer() function. It is needed to load the scripts and stylesheets.
    Except automatic placement, all other methods load scripts and stylesheets in footer since you can't know when header runs if any slideshow is present into the current page to load all files needed.

  3. ghostyzx
    Member
    Posted 2 years ago #

    wp_footer() is called in the theme.
    There seems to be a problem with the "$FA_SLIDERS_PARAMS" variable, it is always empty when the function FA_load_footer is called.
    I'm using WP 3.3.1

    My current workaround is to use automatic placement, but commenting the code that actualy displays the content in featured_articles_slideshow(). This way I can get the shortcode to be displayed where I want it.

  4. constantin.boiangiu
    Member
    Plugin Author

    Posted 2 years ago #

    WP 3.3.1 is fully compatible with current FA Lite. Just tested locally and works fine with shortcodes.
    Can you tell me a little about what you're trying to do? How many slideshows you have in your page? How are they published (automatic, manual, ...)? Maybe I missed a case and it could be the reason why it fails to work.
    Also, what other plugins are you using?

  5. ghostyzx
    Member
    Posted 2 years ago #

    I'm using only one slideshow in a page, set using a shortcode, eg:
    [FA_Lite id="7713"]
    No css or js files are included at all in the footer this way, the result being just a list of articles in plain html.

    I have tried to do some extensive debugging, but I haven't found much.
    The variable $FA_SLIDERS_PARAMS appears to be set correctly in function FA_display_slider(). But when FA_load_footer is called, $FA_SLIDERS_PARAMS is empty.
    Something is messing up the global variables... I have no idea what.

    I have over 40 plugins activated... most important being BudyPress, All in One SEO Pack, Gravity Forms, NewStatPress, MapPress Easy Google Maps, SimpleMap, WP Socializer.

  6. constantin.boiangiu
    Member
    Plugin Author

    Posted 2 years ago #

    If it's possible, you could try and disable plugins one by one and see when/if things start to work. This way you can check if there's a plugin incompatibility and if so, I can try and find a solution for it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic