WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: FD Feedburner Plugin] Feed for Author (6 posts)

  1. array064
    Member
    Posted 5 years ago #

    To accomodating author feed into feedburner with this plugin, I added this code:

    // Get author
    	$author = null;
    	if ($wp->query_vars['author_name'] != null) {
    		$author = $wp->query_vars['author_name'];
    	}
    	if ($author) {
    		$feed_url .= '_author_'.$author;
    	}

    After this line:

    // Get tag
    	$tag = null;
    	if ($wp->query_vars['tag'] != null) {
    		$tag = $wp->query_vars['tag'];
    	}
    	if ($options['feedburner_append_cats'] == 1 && $tag) {
    		$feed_url .= '_'.$tag;
    	}
  2. array064
    Member
    Posted 5 years ago #

    in file fdfeedbuner.php

  3. Fabián
    Member
    Posted 5 years ago #

    Awesome! I disabled the plugin because of that, I can now have it enabled again.

    Thanks!

  4. phmadore
    Member
    Posted 4 years ago #

    I need code which will allow me to NOT redirect author feeds to feedburner. Help!

  5. evanw
    Member
    Posted 4 years ago #

    Same here, is there any way to use this plugin but still retain individual author feeds?

    Thanks!

  6. Lovedoodle
    Member
    Posted 4 years ago #

    phmadore and evanw, here's what I did to retain individual author feeds while using this plugin...

    Open up the main plugin file (FeedBurner_FeedSmith_Plugin.php) and edit the function called ol_feed_redirect() starting on line 109. Just add a conditional && !is_author() to the first portion of the if statement so it looks like this:

    function ol_feed_redirect() {
    	global $wp, $feedburner_settings, $feed, $withcomments;
            if (is_feed() && $feed != 'comments-rss2' && !is_single() && !is_author() && $wp->query_vars['category_name'] == '' && ($withcomments != 1) && trim($feedburner_settings['feedburner_url']) != '') {

    That did the trick for me.

Topic Closed

This topic has been closed to new replies.

About this Topic