WordPress.org

Ready to get started?Download WordPress

Forums

FB LinkedIn Resume
[resolved] Fatal Error Member Function Find() (12 posts)

  1. prighas
    Member
    Posted 2 years ago #

    When I first upgraded wordpress to the latest version, I didn't have any issues using this plugin.

    However, I just realized today this error when attempting to display my LinkedIn profile:

    "Fatal Error: Call to a member function find() on a non-object in
    /fb-linkedin-resume/fb-linkedin-resume.php on line 194".

    I've checked my LinkedIn public profile path and I'm sure it's accurate.

    Is there any way to resolve this?

    And by the way, thank you for this wonderful plugin.

    http://wordpress.org/extend/plugins/fb-linkedin-resume/

  2. thinkless
    Member
    Posted 2 years ago #

    Same issue for me.
    I have found this:
    http://stackoverflow.com/questions/11474447/error-call-to-a-member-function-find-on-a-non-object-in-cakephp-controller
    but I'm not able to make the plugin works anyway.

  3. pleasureinstitute
    Member
    Posted 2 years ago #

    add the language to your username in settings. e.g.

    prighas/en

    instead of just

    prighas

    fixes it for me

  4. prighas
    Member
    Posted 2 years ago #

    Thanks for your response.

    Can you tell me exactly where to add that?

    Below is what I have in settings which is my public linkedin profile:

    http://th.linkedin.com/pub/fName-lName/22/382/285

    I did try adding it like this but it did not work.

    http://th.linkedin.com/pub/fName-lName/en/22/382/285

    Thanks.

  5. fabrizio.balliano
    Member
    Plugin Author

    Posted 2 years ago #

    if you click on this link:
    http://th.linkedin.com/pub/fName-lName/22/382/285

    you'll see it redirects you to:
    http://www.linkedin.com/pub/petros-rigas/22/382/285

    this is the problem (the software cannot handle redirects and those should not happen by the way), use the second link instead of the first one and should be ok.

  6. prighas
    Member
    Posted 2 years ago #

    thanks for the response.

    I actually do have in settings. The reason I showed the previous link is I did not think I should advertise my profile on this site. So I replaced my name with those 'placeholders' - and it turns out that linkedIn is redirecting to my profile.

    again, I do have the below link in the settings page and I still do get that error. Please help.

    http://th.linkedin.com/pub/petros-rigas/22/382/285

  7. fabrizio.balliano
    Member
    Plugin Author

    Posted 2 years ago #

  8. prighas
    Member
    Posted 2 years ago #

    GREAT. It now works. Thanks very much!

  9. fra-lippi
    Member
    Posted 1 year ago #

    It doesn't work to me.
    If I use this code: [fb_linkedin_resume_full] I have this messagge
    Fatal error: Call to a member function find() on a non-object in /home/druidait/public_html/wp-content/plugins/fb-linkedin-resume/fb-linkedin-resume.php on line 194

    (And most of my website desapear)

    If I use -for exempel- a code like that:
    [fb_linkedin_resume_experience title="Experience"]

    Most of the website appear again, but there is no Linkedn resume.

    But my pubblic profile has not a link like those you show,guys:
    If I put this: http://www.linkedin.com/in/francescalippi or this: http://www.linkedin.com/in/francescalippi/sv
    They don't work. Please, what I have to do? I need to fix quickly.

  10. adth
    Member
    Posted 1 year ago #

    add /en
    in the plugin configuration page

    ok for me

    tx!!

  11. fra-lippi
    Member
    Posted 1 year ago #

    ok. Now it's working, thanks a lot. Unfortunately I can not add my Swedish resume as I did before. But, anyway thanks :)

  12. fabrizio.balliano
    Member
    Plugin Author

    Posted 1 year ago #

    which version of the plugin are you using? did you complete the username info in the settings page?

    you should be able to use
    [fb_linkedin_resume_experience user="http://www.linkedin.com/in/francescalippi/sv"]

    it's written in the docs and it's perfectly working on my test page

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic