WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
vcita??? (12 posts)

  1. warpdag
    Member
    Posted 2 years ago #

    First of all, let me thank you for the past versions of your plugin, good stuff. However, I must admit I'm a bit ticked off by the recent updates since the vcita JS was 'quietly' added to them. Why on my installations it calls the JS on EVERY page, instead of the pages that actually call the form? Also, even on the pages with the contact form, if vcita is not selected in the admin options, the JS call shouldn't end up in the html anyway.

    Unnecessary 'bloating', and quite frankly, looks more like a way to make $ for the plugin author rather than an actual feature. If you look into the JS, there's clearly a referral ID in there:

    "&invite=wp-fscf"

    Disappointing. Would love to have an option to disable this once and for all. Meanwhile, I'll disable FSCF, not comfortable with 'quiet' javascripts that include referral IDs on my website.

    http://wordpress.org/extend/plugins/si-contact-form/

  2. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry you are having trouble.
    Thanks for telling me there is a problem. There is a setting on every form to enable or disable vCita. The setting lets you disable it you do not need vCita to schedule meetings, calls, or appointments. Yesterdays update was tested with 15,000 downloads for 1 week before the version number changed and you are the 1st one to notice the 'every page' bug. You are supposed to be able to disable it once and for all. It will be fixed in the next update.

    vcita is a meeting scheduler feature, and some people are using it to schedule meetings, they find it useful. Meeting and appointments was a requested feature by some of the FSCF users. Referral ID are not uncommon on many web sites and applications. This one is mostly used to gauge usage. Again, you are supposed to be able to disable it if you are not going to use vCita. It will be fixed in the next update.

    vCita was announced on the changelog in version 3.1 on on Dec 6, 2011
    http://wordpress.org/extend/plugins/si-contact-form/changelog/

  3. warpdag
    Member
    Posted 2 years ago #

    Mike - Fair enough, and the 'bug' could be theme/installation-specific. Since I like FSCF, I re-enabled it, and for now I tweaked your vcita_si_contact_add_script function to disable the call for the script.

    Cheers,

    warpdag

  4. Nikki Blight
    Member
    Posted 2 years ago #

    Just as a note, I can confirm that I also ran into this bug. Vcita's javascript loads on every page of my site rather than just on the pages with contact forms (and none of my forms have meeting scheduling enabled).

    In my case, it actually caused a conflict with the jCarousel javascript library and broke all of my slideshows. I finally had to just disable it in the code by commenting out the line that prints out the script tag for vcita.

    I'm using a child theme based on TwentyEleven... could be specific to the theme, but other than adding the code for some custom slideshows, it isn't heavily modified from the base theme.

  5. speedygonz
    Member
    Posted 2 years ago #

    Hi,

    I just want to let you know that I have the same problem: vcita script loaded in every page.

    However, I have disabled the Meeting Scheduler in options.

    Too bad, this is the first time I have this kind of problems with this excellent plugin.

    I hope you will be able to fix it in the next release.

  6. Tuscanytrace
    Member
    Posted 2 years ago #

    I see this, and I can't keep Vcita switched off. It turns itself back on when I log out!

  7. 247creative
    Member
    Posted 2 years ago #

    Hi Mike,

    I have always liked this plugin, and one of the main reasons for this is that it hasn't traditionally inserted a whole heap of extra JS/CSS into pages where it isn't being used (unlike certain other contact form plugins out there!)

    As per the other comments in this thread, I would be hugely grateful to see an update which removes any calls to the vCita stuff if it has been explicitly disabled in the settings panel.

    Finally, thanks for taking the time to put together such an excellent plugin - if the above is taken care of, it'll go back to being pretty much perfect :)

  8. Julian
    Member
    Posted 2 years ago #

    I am having the same problem. I noticed it when I was going through my source code today. Contact Form 7 doesn't suit my every need and I've been using FSCF for over a year now. Hopefully it's fixed soon. Luckily no conflicts from what I see but still rather annoying to have a JS on each page.

  9. Joe DDD
    Member
    Posted 2 years ago #

    Same here.

    "Yesterdays update was tested with 15,000 downloads for 1 week before the version number changed and you are the 1st one to notice the 'every page' bug" <= Most likely because people don't check their source, esp. when the js is pushed to the bottom (c'mon man, 15,000 downloads is not the same thing as 15,000 testers who actually look for that kind of bug!).

    Clearly a widespread issue. Simply do a google search for 'vcita_fscf.js' and you'll easily find websites with the js call showing up in the source of all their pages even though they use the contact form on only one or two pages.

  10. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    Please try the new version 3.1.2 it has the fixes for these issues.

  11. Tuscanytrace
    Member
    Posted 2 years ago #

    Is it in the repository yet? I'm not seeing an auto-upgrade yet on my installation.

  12. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    Yes, it is there. It can take awhile for your WP to notice, if it has recently checked for updates prior to the new update.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic