WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
Update issue - server won't release the ttf file to be delet (6 posts)

  1. AardvarkGirl
    Member
    Posted 3 years ago #

    I know this isn't specific to THIS plug-in, but seems to be related to any plug-in I've used with captcha.

    I can't get the plug-in to up date... I can't delete the plug in from the server because it won't release the use of ahg-bold.ttf.

    Again, this isn't just because of this plug in. I had this exact same issue with another WP site and a totally different captcha plug-in using this font. The server will not let me delete it because it says it is being used.

    I had this issue a few months ago and had to get the big boss to get on the server to kill it. Had it yesterday... had to ask the big boss again (who grumbed and grumbed).

    Scared to ask the big boss to do it again today. :-\

    Any clue as to WHY this is happening (we have windows with... arrr... IIS 6 I think but can look for sure).

    BUUUUUT in the meanwhile the plug-in update didn't work, and now the plug-in is totally gone from my list of plug-ins in wordpress.

    (oiy)

  2. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Some severs can do this, a locked font file for the captcha. I do not know why it does this. I never have it happen on my Linux servers.

    Before you contact your web host to remove the locked file... you could try a manual install(let me know if that works).

    Manual Install:
    Download the Fast Secure Contact Form zip file:
    http://downloads.wordpress.org/plugin/si-contact-form.zip
    Unzip the file on your computer.
    Use a FTP program such as FileZilla to connect to your web server .
    FTP File Transfer this folder this folder: /si-contact-form/ from your downloaded files to the folder on your server: /wp-content/plugins/
    On the plugins admin page, find Fast Secure Contact Form and click “Activate”. The plugin will now be activated.

    See FAQ
    http://www.fastsecurecontactform.com/reinstall-wordpress-version

  3. AardvarkGirl
    Member
    Posted 3 years ago #

    Ok a manual update worked fine.

    ;-) I was mostly just curious what the deal was with the server not letting go of this file.

  4. denise032
    Member
    Posted 2 years ago #

    I have the same issue every time I update. The plug-in will delete all the files with the exception of ahg-bold which makes the update process stop. I've even tried deactivating for up to 10 minutes.

    To avoid the issue, every time there is an update to the plug-in I have to manually download and install it. Is there any way possible to avoid this?

  5. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    denise032, it is a rare server related cause. But you could try deactivate the plugin then wait about 5 minutes before updating next time

    Here is the help page for that
    http://www.fastsecurecontactform.com/reinstall-wordpress-version

    faq
    http://www.fastsecurecontactform.com/faq

  6. denise032
    Member
    Posted 2 years ago #

    Thanks for the fast response, Mike. I've even tried deactivating for up to 10 minutes, but still no luck. I guess I'll just continue manual updates. :(

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic