WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
[resolved] Unable to attach PDF files (10 posts)

  1. john7012
    Member
    Posted 2 years ago #

    I have created an order form using Fast Secure Contact Form plugin for my website, in which users may attach a proof of payment, in pdf, doc, txt, gif, jpg, jpeg or png format. The strange thing is that everything works fine, except when a pdf file is attached. When a pdf file is attached (smaller in size than the 1 mb specified) the following message is displayed and no email is sent:

    "Internal Server Error. The server encountered an internal error or misconfiguration and was unable to complete your request ...". Sometimes, when I start with my efforts to attach a pdf file, it will work the first time I try, but after that the same "Internal Server Error" message is given time and again. This happens only with pdf attachments, not with any of the other attachment types allowed on the page.

    Have tried to disable other plugins but with no success. Can anyone please help?!!

    http://wordpress.org/extend/plugins/si-contact-form/

  2. john7012
    Member
    Posted 2 years ago #

    I have tested again and realized that I was wrong about the pdf files being the only culprit. It is NOT the file type that causes the "Internal Server Error" but the file size. Any file (of any type allowed) that is a little bit bigger than 100 kb is rejected and gets the error message. If the attached file is smaller than 100 kb, the order is allowed and the correct email is sent, with the attachment. Is there any way that this problem can be corrected? The maximum file size allowed as specified in the FS Contact Form Options is 1 mb. May this perhaps be a server restriction and what can one do to change this?

  3. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    Look on the form edit page, click "help" next to this setting
    "Attached files maximum size allowed"
    The text that appears will show you what your server limit is for file uploads: Your server will not allow uploading files larger than than: XX
    What does it say?

  4. john7012
    Member
    Posted 2 years ago #

    Thanks for answering so soon, Mike. In the "help" note it says: "Your server will not allow uploading files larger than than: 2mb". Looks like there is a setting somewhere that prevents the plugin to upload files to its full capacity ...

  5. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    2mb is really low, that is probably the cause, even though your files are smaller.
    There are 3 settings in php.ini effecting that:
    One of them is probably set to 2m and should be increased.
    upload_max_filesize
    post_max_size
    memory_limit

  6. john7012
    Member
    Posted 2 years ago #

    Thanks for your help, Mike. The problem was with the website host. They made an adjustment (I think it had to do with the upload time) and everything is working fine now.

  7. Carrizo
    Member
    Posted 2 years ago #

    Can somebody tell me where my attachments go? please? I believe I did everything right but when i test the form and I upload the image i dont get it in my email, where does it go? I tried using GEEKMAIL and ofcourse WORDPRESS what the Hell is wrong?

  8. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    Here is the help page for attachments.
    http://www.fastsecurecontactform.com/attachment-fields

  9. xiexiema
    Member
    Posted 2 years ago #

    Hi Mike, I am loving this plugin and it gets more and more useful.

    I will donate - I always do. I just have one problem which is stopping me from using it. It is to do with regex on an attachment field.

    I have set up a regex to allow only a certain file name (with slight variation) but every file seems to get through.

    I have used some regex on other fields and they seem fine (after a little adjusting).

    So for example I have in an attachment field regex area:

    /info\d{12}\.zip/

    The file I need to accept is info201223051245.zip for example.

    Problem is the plugin seems to allow any file to be uploaded. (I have set to zip only so that does help a bit).

    So any idea? Does regex actually work on an attachment field?

    Thanks in advance for any help.

    :-)

  10. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    Does regex actually work on an attachment field?
    No it does not.

    The proper way to limit file types is with the "Attached files acceptable types" setting on the form edit page. Set the acceptable file types for the file attachment feature. Any file type not on this list will be rejected. Separate each file type with a comma character. example: doc,pdf,txt,gif,jpg,jpeg,png

    FAQ
    http://www.fastsecurecontactform.com/faq

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic