WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
Strange bug: Only works if making an error first (6 posts)

  1. Olivier
    Member
    Posted 3 years ago #

    If I try to use the form, instead of seeing the confirmation message, I just get a page refresh (including empty fields).

    Now, if I omit to fill a required field, I will get an error message and if I complete that field and hit send, then it works.

    Any idea why this happens? There are no errors in the logs.

  2. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Maybe another plugin is conflicting.
    Look on the Admin - Plugins - menu.
    Temporarily Disable (not uninstall) all your other plugins.
    Does it work now? If yes, Activate the plugins one by one to determine
    which one conflicts. Which plugin was causing it?

    -----------------

    It could be the theme you are using is causing it...
    Do this as a test:
    In Admin, click on Appearance, Themes.
    Temporarily change your theme to the "WordPress Default" theme, or "Twenty Ten" (default for WP 3.0).
    It does not cause any harm to temporarily change the theme and change back.
    Does it work properly now?
    If it does then the theme you are using is the cause.

    -----------------

    If you still need help, I need URL to your form to help you. Thanks

    Mike

  3. Olivier
    Member
    Posted 3 years ago #

    I've tried already and it's not related to plugins or themes afaict.
    I don't get why there needs to be an error first for everything to be loaded properly.

    While looking at logs, I've found an unrelated problem that you may want to fix in the next release:
    PHP Fatal error: Using $this when not in object context in /wp-content/plugins/si-contact-form/si-contact-form-ex-fields.php on line 71

  4. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    That error should not happen, I cannot find anything wrong with the code. Try reinstalling the plugin.
    http://www.fastsecurecontactform.com/reinstall-wordpress-version

    Also you did not give me a URL to your form

    Mike

  5. Olivier
    Member
    Posted 3 years ago #

    I think I may have found the problem.
    The site switches to the SSL URL once I hit submit. I'm trying to find out why.

  6. Olivier
    Member
    Posted 3 years ago #

    Regarding the fatal error, I'll let you know if I can reproduce it.
    And regarding the form submission problem, it seems I'm being redirected to the SSL version of the page when sending submit. I've fixed this by making the page SSL only, so that data is sent securely, but I still have no idea why the plugin switches between the two.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic