WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
Redirecting broken. Help please (17 posts)

  1. delapuravida
    Member
    Posted 2 years ago #

    Hi. My contact form is now redirecting to itself?
    It goes from http://www.delapuravida.com/contact/
    to
    http://www.delapuravida.com/contact/#FSContact1

    I've run out of ideas on how to fix this. If I disable the theme and then re-enable it, will all the edits I've made still be there or will it delete those?
    Thanks for any help!

    http://wordpress.org/extend/plugins/si-contact-form/

  2. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    You say "redirecting is broken", but what are you wanting it to do?
    Do you have the redirect setting enabled or disabled?
    What did you put for the redirect setting?

    Nothing is wrong with the #FSContact1 on the URL, that is a feature that makes the browser focus go to the form. This feature is most appreciated if you have a long page and/or when you have more than one form on a page.

  3. delapuravida
    Member
    Posted 2 years ago #

    Thanks for your response!
    Redirect is enabled. After submission, it should redirect to URL: http://www.delapuravida.com/thank-you
    but instead it brings up this page with a blank form:
    http://www.delapuravida.com/contact/#FSContact1

    Because of this, I have people sending me 2 or 3 forms thinking that their message failed.

  4. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    Make sure you use a full URL in the redirect setting
    http://www.delapuravida.com/thank-you
    do not put as /thank-you

  5. delapuravida
    Member
    Posted 2 years ago #

    It's a full URL.

  6. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    Then maybe you have a conflicting theme or plugin breaking the redirect javascript.

    Maybe another plugin is conflicting.
    Look on the Admin - Plugins - menu.
    Temporarily Disable (not uninstall) all your other plugins.
    Does it work now? If yes, Activate the plugins one by one to determine
    which one conflicts. Which plugin was causing it?

    -----------------

    It could be the theme you are using is causing it...
    Do this as a test:
    In Admin, click on Appearance, Themes.
    Temporarily change your theme to the stock theme:
    “WordPress Default” (default for WP 2.0+)
    “Twenty Ten” (default for WP 3.0+)
    “Twenty Eleven” (default for WP 3.2+)
    It does not cause any harm to temporarily change the theme and change back.
    Does it work properly now?
    If it does then the theme you are using is the cause.

  7. delapuravida
    Member
    Posted 2 years ago #

    Will temporarily disabling a plugin or changing a theme cause any custom modifications to be deleted?

  8. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    No

  9. dschommer
    Member
    Posted 2 years ago #

    I am having the exact same problem, full URL redirect, everything. I get the exact same redirect page of #FSContact1 running 3.0.5 version of the plugin.

    This used to work fine, but now ... not so much.

  10. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    dschommer, then you have a theme or plugin causing the problem, see my reply above.

  11. dschommer
    Member
    Posted 2 years ago #

    .. that was painful, but I found it. It's Simple Facebook Connect which is causing the problem.

  12. johnlagoudakis
    Member
    Posted 2 years ago #

    I was having this same issue but noticed that it only happened after I added some fields to the basic template.

    After much time, I finally found what was causing the problem...

    If I put a full url in one of the fields, e.g. "http://wordpress.org", I would get the blank page with /#FSContact1. But if I was to take away the "http://" so that I only entered "wordpress.org" into the field, the form would submit successfully.

    Hopefully Mike can fix this bug?

    Thanks,

    John

    P.S. This is an awesome plugin.

  13. delapuravida
    Member
    Posted 2 years ago #

    Finally found the time to investigate. Turns out it was the plugin Facebook Like Thumbnail that was causing the problem on my site. Thought I'd share in case anyone else runs into the problem in the future.

  14. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

  15. danskkr
    Member
    Posted 2 years ago #

    Same here. Redirect not working, but appears its due to the conflict with Simple Facebook Connect plug in.

    I want to keep both plug ins - did anyone find any work arounds?

  16. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    Simple Facebook Connect plugin causes unresolvable conflicts, I suggest the plugin "Share and Follow" instead.
    http://www.fastsecurecontactform.com/error-message-sfc-like

    FAQ
    http://www.fastsecurecontactform.com/faq

  17. Krzysztof Kaczmarek
    Member
    Posted 2 years ago #

    Is it possible to fix it via .htaccess rewrite rule?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic