WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Fast Secure Contact Form] Not receiving emails on same domain (1 post)

  1. AardvarkGirl
    Member
    Posted 1 year ago #

    This is the 4th website I am having this issue with.

    All sites are hosted on HostGator, all email is being run through Google Apps (for domains), including the alternate/test email addresses from a different domain. We have logged in via a browser and checked the spam folder for the emails.

    The site is hosted on the same domain as the email the form is to go to (TheirWebSite.com for example). If I use info@TheirWebsite.com the form works on the front end but we never receive the email. They are not ending up in spam folders. We have put TheirWebSite.com on the safe / please give me these emails list.

    If I change the email address to me@SomeOtherDomain.com we get the form's email.

    If I use the 'Send A Test Email' button on the form admin page, I do not get any errors, but the results are the same as above.

    I can use the info@TheirWebSite.com email address on SomeOtherDomain.com's wordpress FSC-form and it receives the form. But neither domain can receive email from their own email accounts.

    This is the 4th website where we are having this issue, and a co-worker of mine has posted about this 2 weeks ago.

    We have followed the instructions on this page http://www.fastsecurecontactform.com/email-does-not-send

    I even upgraded the plugin to 3.1.5.6 and it still doesn't work. All the wordpress sites in question are 3.4.X versions. All of these sites are built on child 2010 or 2011 themes.

    Thank you. :)

Topic Closed

This topic has been closed to new replies.

About this Topic