WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
Fatal error: Allowed memory size (4 posts)

  1. falopiuss
    Member
    Posted 3 years ago #

    Sorry for my bad english. Two questions:
    1) I'm running WP version 3.04, with this plugin, and 'Broken Link Checker' -normally deactivated-, 'Google XML Sitemaps' and 'Limit Login Attempts', all of them upgraded to last version.
    My site is in a shared hosting -with Asmallorange.com-.
    I see in the dashboard area the same error for the WP developer blog, Incoming links and Plugins boxes:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /.../.../public_html/wp-includes/class-simplepie.php on line 14908

    I've deactivated all the plugins and then tried to activate one by one: the culprit is Fast Secure Contact Form.
    I have 2 forms in my site, and they seem to work well.
    I had implemented time ago the wp-config.php lines:
    define('WP_MEMORY_LIMIT', '64M');
    but this is not a solution.
    The parameters in php.ini are ok, like you suggest for your plugin, including:
    memory_limit = 64M
    Other parameters modified from the default in php.ini are:
    allow_call_time_pass_reference = Off
    disable_functions = dl,system,exec,passthru,shell_exec,proc_close,escapeshellcmd,proc_open
    ignore_user_abort = On
    expose_php = Off
    display_errors = Off
    display_startup_errors = Off
    register_long_arrays = Off
    register_argc_argv = Off
    magic_quotes_gpc = Off
    file_uploads = Off
    upload_max_filesize = 7M
    allow_url_fopen = Off
    extension=php_openssl.dll
    date.timezone = "Europe/Paris"

    I've even tried to add
    ini_set('memory_limit','64M');
    to the top of the cache.php file, after the initial <?php but to no avail.

    class-phpmailer.php and class-smtp.php, in the wp-includes folder, are version 5.1, downloaded from phpmailer.sourceforge.net
    I don't remember exactly why I put these updated files there, maybe trying some other contact-form plugin, but don't think this will be significant.

    jquery.js, in the wp-includes\js\jquery folder, is version 1.5, downloaded from jquery.com (the same occurs with previous version 1.4.2)

    wp-config.php is not placed in the public_html directory -the same as WP-, but in the previous root directory.

    What do you think can be the cause of these errors?

    2) I like your plugin, because I privilege the security in my site. But I don't need the CAPTCHA function. What folders and/or files can I avoid to upload to my server if I don't need this function? (captcha-secureimage folder takes about 1,5MB). Must I also change or comment some line in some php file of you plugin to achieve this?

    Many thanks in advance

  2. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    If you are having memory problems you are not able to resolve. Talk to your web host support department about their recommended solution.

    (also make sure your server is PHP5, not PHP4)
    PHP5 is more secure and more reliable. PHP4 is discontinued.

    About the captcha, you can turn off CAPTCHA on the form edit page.
    You might be able to delete the /captcha-secureimage/ folder but then you would get an error if the CAPTCHA is turned back on. Do you really need to try to save 1.5 megs space?

  3. falopiuss
    Member
    Posted 3 years ago #

    (Again, sorry for my poor english)

    Many thanks for your attention.
    PHP version is 5.
    My host provider says they offer only 32 Mb of memory. I know this is a very common feature for shared accounts. An I agree with they: "32MB should be reasonable for any shared hosting script".
    Maybe some script or function of your plugin really reach more than 32 Mb?
    I thinked it was a matter about my theme, but the problem reproduces with the default wp theme.
    I'm very cautious resizing images, scripts and other files, just to avoid this issue with the RAM use.
    I've seen in some forums that it could be a bug in WordPress about this question, maybe a some years ago problem and still unresolved. Who knows.
    Also, I'm going to delete and reupload all the WordPress files.

    I had forgotten to mention that I'm using your plugin -the shortcode- not in a page, but in a pair of sticky posts. And it works, despite your instructions. May this can be the cause of the problem?

    I could try with another plugin, but I think is interesting to find the origin of the problem, probably I will learn something.

    Sorry for make you waste your time with it, and thanks again.

  4. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    > "My host provider says they offer only 32 Mb of memory."
    Then the solution might be to get a new host.
    My host (HostGator) gives me 256M

    Many WP sites will need more than 32M.
    Plugins require more memory. Also WP has to run on many different platforms, PHP4 and PHP5, so the code will be increased because of that.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic