WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
[resolved] Error: A checkbox field is not configured properly in settings. (34 posts)

  1. tspaulding
    Member
    Posted 2 years ago #

    Hello,

    I would like to know why this error message Plugin: Fast Secure Contact Form] Error: A checkbox field is not configured properly in settings is showing up on my contact form? It wasn't like this before and I have been using it for over a year now. See http://www.creativestagingco.com/contact/

    Thank you,
    Tia

    http://wordpress.org/extend/plugins/si-contact-form/

  2. DannyEatsYou
    Member
    Posted 2 years ago #

    Hello!

    I had the same issue and managed to solve it by looking into the settings of the "broken" form.

    I noticed that the German translation of check box ("Kontrollkästchen") was selected as the input type and that right below this there was an option called "checkbox-multiple". After I selected this one and saved the settings that ugly error message was gone! :)

    Hope that helps!

    Cheers

  3. losereit
    Member
    Posted 2 years ago #

    Yes, but, if you have more than one option and only want one checked this doesn't help.

  4. DoubleG
    Member
    Posted 2 years ago #

    I'm having a real problem with this one too!

    It seems to have appeared out of nowhere with a form I've been happily using for 18 months! Surely it must be the recent update? I've just noticed the recent update note says:

    3.1.5.4
    (12 May 2012) - Better detection of checkbox config errors.

    Thing is . . . . I've checked my coding via the FastSecureContact Form website instructions. see link
    http://www.fastsecurecontactform.com/how-to-add-extra-fields
    and I can't see any error!!!

    The code I used in 2 of the extra fields (when I originally built the forms 18 months ago) are as follows:
    {inline},BA;MA;PHD;Other
    &
    {inline},French;German;Italian;Spanish;Mandarin;Other

    The form which these parameters are used in is here:
    http://www.sophiemacpherson.com/?page_id=314

    Any ideas anyone?

  5. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    when you're using a single check box make sure the type is checkbox.
    Do not use type checkbox-multiple for a single check box

    These are both incorrect as the are mussing the label before the comma
    {inline},BA;MA;PHD;Other
    &
    {inline},French;German;Italian;Spanish;Mandarin;Other

    Like this would be correct
    {inline}Qualifications,BA;MA;PHD;Other
    &
    {inline}Languages,French;German;Italian;Spanish;Mandarin;Other

  6. proverbs31woman
    Member
    Posted 1 year ago #

    Mike, I've tried the last example you have above and replaced the text for my own criteria but it's not working.

    Mine is at http://avaa.asn.au/join-now/

    I have tried so many different variations but still can't get it to work.

  7. joerebuildhitor
    Member
    Posted 1 year ago #

    I am also having the same issue and can not figure it out. You can view the form here: Rebuild Hi-Tor Test page
    Thanks, any help is appreciated.

  8. joerebuildhitor
    Member
    Posted 1 year ago #

    Ok. so i went thru the rest of the forum and found it in a answer from 2 years ago. I had a "," in the label.

  9. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    Version 4.0 is coming soon and extra fields will be really easy.
    no more comas semicolons to separate the options

    Label: Languages

    Options: (inside a textarea)
    French
    German
    Italian
    Spanish
    Mandarin
    Other

  10. raecp
    Member
    Posted 1 year ago #

    Thank You for the "," clue! That was my problem!

  11. tomgeijn
    Member
    Posted 1 year ago #

    I too have tried everything without any result. Can you take a peek at this site:
    http://www.voetbalacademietop.nl/inschrijven/nieuwe-inschrijving/

  12. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    tomgeijn,

    Follow the instructions exactly. If you need help, post what you have set for the extra field label
    http://www.fastsecurecontactform.com/how-to-add-extra-fields

  13. tomgeijn
    Member
    Posted 1 year ago #

    Well. I've read it now about thirty times but I really can't see what I'm doing wrong.
    I've put this in the extra field: Activiteit:,voorjaarscursus;najaarscursus;clinic
    And the label Activiteit is set as checkbox-multiple.

  14. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    That label was fine but now you have an error because you it set to checkbox? Try a different type: Checkbox-multiple, Radio, Select, or Select-multiple

  15. tomgeijn
    Member
    Posted 1 year ago #

    I had set checkbox-multiple.
    Now I've set the "Radio" configuration, again with the same disappointing result.
    Can you please take a look at it?

  16. gorillaagent
    Member
    Posted 1 year ago #

    There is a field called attributes. Add a comma to that box.

    Then if you have multiple check box selected you would add the comma first, then comma separate the variables.

    Note: Make sure your label does not have any commas in it.

  17. nohler
    Member
    Posted 1 year ago #

    We have ours set to: Reason for Contact:,Monthly Newsletter;Weekly Mediation Circle;Comment;Training;Individual Session

    Are we getting the error because of the spaces? is there an escape character for spaces?
    Also, it won't stay set on checkbox-multiple - it keeps reverting to checkbox after we preview it.

  18. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    nohler,

    I have no problem with that setting for checkbox-multiple
    The spaces are OK.

    if settings do not stay, make sure you are clicking "Update Options" before clicking "view" to preview the form.

    if settings still do not stay, check for this problem on your server:
    http://www.fastsecurecontactform.com/settings-cannot-be-saved

  19. nohler
    Member
    Posted 1 year ago #

    I removed the space in the label and put periods (".") in place of the spaces and the error went away. Is that a configuration issue?

  20. oozandoz
    Member
    Posted 1 year ago #

    I made changes (e.g. eliminated the lists, kept Morph-O-Scopes Kits), clicked "Update Options" and then "View". Changes show up properly in "view" but aren't appearing on the form itself. http://oozandoz.com/wholesale-buyer-registration-form-2/

  21. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    oozandoz, you put commas in the option names but did not escape them with slashes

    If you need to use a comma besides the one needed to separate the label, escape it with a back slash, like this: \,

    http://www.fastsecurecontactform.com/how-to-add-extra-fields

  22. oozandoz
    Member
    Posted 1 year ago #

    I changed the label - eliminating the names (which are not options, by the way) and keeping just "Morph-O-Scopes Kits", the change is viewable, but doesn't appear on my site. I refresh, but still the old error messages and old config is there.

  23. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    If your site has a caching plugin and you make changes, you may need to empty the cache to immediately see the changes.

  24. oozandoz
    Member
    Posted 1 year ago #

    I'm told my site doesn't have a caching plugin. Browser has a cache. Is that what you meant?

  25. oozandoz
    Member
    Posted 1 year ago #

    Hello?

  26. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    You have to escape the commas like this:
    Morph-O-Scopes Packets - Dinos\, Fairies\, Pets\, Pajama Party

  27. oozandoz
    Member
    Posted 1 year ago #

    Mike, I eliminated the lists and kept only the categories - like Morph-O-Scopes Packets. Those changes show up fine in the View mode, but the changes don't get made live. Back to the issue of caching.

  28. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    Is it changed in the settings?

    What about when you preview the form?
    http://www.fastsecurecontactform.com/tip-form-preview

    If the answer is no to both, maybe you have this problem
    http://www.fastsecurecontactform.com/settings-cannot-be-saved

  29. oozandoz
    Member
    Posted 1 year ago #

    Yes, it changed in the settings and changed in preview of form, but not live.

  30. oozandoz
    Member
    Posted 1 year ago #

    I also just entered labels with the escaped commas and still no live change.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic