WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
After submit problem (9 posts)

  1. babrees
    Member
    Posted 3 years ago #

    First of all thank you for this great plugin!

    I have a problem with the redirect. After submitting I get the error:
    Warning: Invalid argument supplied for foreach() in /home/photo123/public_html/jillyblog/wp-content/plugins/si-contact-form/si-contact-form.php on line 474

    I checked the redirect box and entered http://www.123photographs.co.uk/thank-you/ in the url box.

    I then tried the default url (ie index.php). No difference.

    I then unchecked the redirect. No difference.

    I tried changing the theme by reverting back to the default, twenty ten - no change.

    I tried deactivating all other plugins - no change.

    TIA
    Jill

  2. babrees
    Member
    Posted 3 years ago #

    ok, so after spending all morning on this, trying it different ways etc. I have just turned off the redirect again, but this time it worked!

    Fingers crossed that it carries on working and I shall forget the redirect!

  3. brancht
    Member
    Posted 3 years ago #

    I have the same problem on the same line. I had to set a redirect in order to get it to work. It will not work with the redirect turned off...

    Tom

  4. hotsoup
    Member
    Posted 3 years ago #

    I just installed Fast Secure Contact Form and get that error on line 474 also.

    I'm using Form 1 on WordPress 3.0.4 with the Thesis Theme (version 1.8). I didn't make any changes to the default settings at first, but since then I've tried changing the redirect link and turning it off altogether. It didn't seem to help.

    The email messages are being delivered successfully though.

  5. hotsoup
    Member
    Posted 3 years ago #

    Interesting...

    The problem went away after I turned on the redirect link again.

  6. Kluk
    Member
    Posted 3 years ago #

    I had the same problem as Brancht mentioned:
    I had to set a redirect in order to get it to work. It will not work with the redirect turned off...
    And the email messages are being delivered successfully though but there is no registration on the Contact Form 7 to Database Extension's database

  7. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Woke up this morning to 2 critical bug reports in 2.9.8.1, so 2.9.8.2 is released with the fix. Upgrade to 2.9.8.2 to resolve the problems:

    - Fix critical error "invalid argument supplied foreach () /si-contact-form.php on line 474". Sorry for the inconvenience.
    - Fix "Enable data export after the message" setting would not uncheck.
    - Changed default setting: If you use Contact Form 7 to DB Extension Plugin, be sure to visit the form edit page and enable this setting: "Enable data export after the message", because it is not enabled by default.

  8. brancht
    Member
    Posted 3 years ago #

    Mike,

    As usual, you're the man! Thanks for all you do...

    Tom

  9. babrees
    Member
    Posted 3 years ago #

    Mike - that's fantastic! thanks a lot!

    Jill

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic