WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Fast and Secure Contact Form] only one from is working (11 posts)

  1. Simply Seath
    Member
    Posted 4 years ago #

    First I like to say Thank you for your work and your time you are puting in this plugin.

    I have contact form [si-contact-form form='1'] on my contact page :

  2. http://northiowafoodcritic.com/contact/
  3. and [si-contact-form form='2'] on my sponsor page:

  4. http://northiowafoodcritic.com/sponsors-advertisement/
  5. The problem is the second contact on sponsor page is the first contact form for some reason.

    Can you look at it and let me know if you have idea if I am doing something wrong or what is going on.

    I am using the latest wordpress and Fast and Secure Contact Form

    Thank you

    http://wordpress.org/extend/plugins/si-contact-form/

  • Mike Challis
    Member
    Posted 4 years ago #

    Sometimes other plugins break the shortcode functions. Try disabling other plugins to see if one is causing that.

    Mike

  • dmcagulada
    Member
    Posted 4 years ago #

    I have the same problem, I tried deactivating all but your plugin and it still only shows Form 1. I am currently using wordpress 2.9.2

  • Mike Challis
    Member
    Posted 4 years ago #

    Shortcode not working is not caused by this plugin.

    Some plugins break the wordpress shortcode feature.
    "Donate Plus" is one of them.

    Maybe another plugin is conflicting.
    Do this as a test:
    Temporarily disable all your other plugins.
    Does it work now? If yes, enable the plugins one by one to determine
    which one conflicts. Which plugin was causing it?

    It could be the theme you are using is causing it...
    Do this as a test:
    In Admin, click on Appearance, Themes.
    Temporarily change your theme to the "WordPress Default" theme.
    Does it work properly now?
    If it does then the theme you are using is the cause.

    One user said:
    "I figured it out. I'm using Thesis theme and on the pages where I failed to put in the SEO Title & Description meta information, all shortcodes were ignored--not just yours, but any shortcode. Very weird."

  • kalariak
    Member
    Posted 3 years ago #

    I have the same problem, two different forms 1 & 2 on different pages. I deactivated all plugins and it only shows Form 1 on both pages. I changed the theme but still not working. currently using 2.9.2

    Any ideas?

  • Mike Challis
    Member
    Posted 3 years ago #

    Most likely your WordPress has broken shortcode.
    Anybody asking for help... Please post a URL to the page with problem. Thanks

  • OLennox
    Member
    Posted 3 years ago #

    I've also got this problem. I'm using other plug ins (such as the Next gen Gallery) which use shortcode and these are working correctly. I'm Using 2.9.2

    My site is not online so cannot post url.

    Cheers,

  • OLennox
    Member
    Posted 3 years ago #

    Hi, Solved this:

    drop the quotes from the "form" parameter so:

    [si_contact_form form=2]

    I'm new to PHP but imagine it might be the is_numeric() check:

    extract(shortcode_atts(array( 'form' => '' ), $atts));
    $form_num = '';
    $form_id_num = 1;
    if ( isset($form) && is_numeric($form) && $form <= $si_contact_gb_mf['max_forms'] ) {
    $form_num = (int)$form;
    $form_id_num = (int)$form;
    if ($form_num == 1)
    $form_num = '';
    }

    Cheers for all you hard work with this,

    Olly

  • Mike Challis
    Member
    Posted 3 years ago #

    OLennox,

    Would you be able to help me verify the problem before I make any changes?
    Please contact me here to continue;
    http://www.642weather.com/weather/wxblog/support/

  • disenchanted86
    Member
    Posted 3 years ago #

    Hi I am use SI CONTACT FORM Version: 2.7.3 on my web and have found out that the cause of the issue is the reCAPTCHA plugin. Though I have tried to disable the reCAPTCHA plugin and it did make the SI CONTACT FORM to work.

    I think the issue here is with the captcha since the SI CONTACT FORM has CAPTCHA integrated on it. But my Dilemma is that I am using the recaptcha for my registration page and post reply comments.

    I have tried to disable the reCaptcha plugin then enable the SI CONTACT FORM. After, I did disable the integrated captcha on the SI FORM then save and then enable the recaptcha plugin again but after that I am no longer able to edit the SI FORM, just doesn't work if reCaptcha is enable. Any thoughts?

    Many thanks.

  • Mike Challis
    Member
    Posted 3 years ago #

    Why did you hijack an old thread?

    Sorry I do not know the cause of the problem. There are many reCAPTCHA pligins, which one?

    Maybe try removing the reCAPTCHA plugin and using my popular
    SI CAPTCHA Anti-Spam
    http://wordpress.org/extend/plugins/si-captcha-for-wordpress/

    SI CAPTCHA Anti-Spam protects comments and registration.

  • Topic Closed

    This topic has been closed to new replies.

    About this Topic

    Tags