WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
[resolved] [Plugin: Fast and Secure Contact Form] Email header 'FROM' display autofilled email address (6 posts)

  1. daturawp
    Member
    Posted 4 years ago #

    Is there a way to have the email header 'FROM' display the email that was autofilled or entered in the 'Email Addresses' field instead of the administrator email.

    Thanks again.

    http://wordpress.org/extend/plugins/si-contact-form/

  2. Mike Challis
    Member
    Plugin Author

    Posted 4 years ago #

    It does by default.
    Unless...
    Have you set the "E-mail From (optional):"?
    Have you set the the Name or E-mail fields to "Not Available" or "Not Required"?

    When asking for help, please post a URL to your form, otherwise my answer can only be generalized.

  3. daturawp
    Member
    Posted 4 years ago #

    I haven't gone live with the form yet Mike. Sorry :(.

    I mean the header, not the body:

    Right now this is what the recipient sees:

    From: WordPress <admin@website.com>
    Subject: Website contact form enquiry.
    Date: 21 June 2010 4:00:51 PM AEST
    To: admin@website.com
    Reply-To: Logged in User <username@userwebsite.com>

    I want the 'From' address and the 'Reply-To' address to be the same. The email address they used when the registered (which is the same one that gets autofilled).

    Thanks again.

  4. daturawp
    Member
    Posted 4 years ago #

    Fixed it myself based on your questions:

    Have you set the the Name or E-mail fields to "Not Available" or "Not Required"?

    I made the 'Name' and 'Email' address fields visible and that did it.

    THANKS!!!!

  5. amanda72
    Member
    Posted 4 years ago #

    I think i'm having the same problem but I cannot find where you made the 'Name' and 'Email' address fields visible. Have set the name and email fields to 'required' but still not sorting the problem.

  6. Mike Challis
    Member
    Plugin Author

    Posted 4 years ago #

    Please reply with URL when asking for help. There are more settings available when you click "Advanced Options".

    The email header 'FROM' will NOT display the email that was autofilled or entered in the 'Email Addresses' when any of the following settings apply:
    1. You have set the "E-mail From (optional)"
    2. You have set the the "Name" or "E-mail" fields to "Not Available" or "Not Required".

    Mike

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic