WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
[Plugin: Fast and Secure Contact Form] not receiving emails after 3.0 upgrade (8 posts)

  1. kcjson15
    Member
    Posted 4 years ago #

    The form was working fine. Then I upgraded to 3.0 and I get an error the site that says "the email could not be sent". I have tried with and w/o an email in the optional "from" section. This is the error I get when I try to send a test email to a gmail account or an account on my domain:

    The result was:
    bool(false)
    The full debugging output is shown below:
    object(PHPMailer)#44 (45) {
    ["Priority"]=>
    int(3)
    ["CharSet"]=>
    string(5) "UTF-8"
    ["ContentType"]=>
    string(10) "text/plain"
    ["Encoding"]=>
    string(4) "8bit"
    ["ErrorInfo"]=>
    string(36) "Could not instantiate mail function."
    ["From"]=>
    string(28) "wordpress@amuseboucheent.com"
    ["FromName"]=>
    string(9) "WordPress"
    ["Sender"]=>
    string(0) ""
    ["Subject"]=>
    string(31) "Test mail to myemail@mail.com"
    ["Body"]=>
    string(83) "This is a test mail generated by the Fast and Secure Contact Form WordPress plugin."
    ["AltBody"]=>
    string(0) ""
    ["WordWrap"]=>
    int(0)
    ["Mailer"]=>
    string(4) "mail"
    ["Sendmail"]=>
    string(18) "/usr/sbin/sendmail"
    ["PluginDir"]=>
    string(0) ""
    ["Version"]=>
    string(5) "2.0.4"
    ["ConfirmReadingTo"]=>
    string(0) ""
    ["Hostname"]=>
    string(0) ""
    ["MessageID"]=>
    string(0) ""
    ["Host"]=>
    string(9) "localhost"
    ["Port"]=>
    int(25)
    ["Helo"]=>
    string(0) ""
    ["SMTPSecure"]=>
    string(0) ""
    ["SMTPAuth"]=>
    bool(false)
    ["Username"]=>
    string(0) ""
    ["Password"]=>
    string(0) ""
    ["Timeout"]=>
    int(10)
    ["SMTPDebug"]=>
    int(2)
    ["SMTPKeepAlive"]=>
    bool(false)
    ["SingleTo"]=>
    bool(false)
    ["smtp"]=>
    NULL
    ["to"]=>
    array(1) {
    [0]=>
    array(2) {
    [0]=>
    string(18) "myemail@mail.com"
    [1]=>
    string(0) ""
    }
    }
    ["cc"]=>
    array(0) {
    }
    ["bcc"]=>
    array(0) {
    }
    ["ReplyTo"]=>
    array(0) {
    }
    ["attachment"]=>
    array(0) {
    }
    ["CustomHeader"]=>
    array(0) {
    }
    ["message_type"]=>
    string(5) "plain"
    ["boundary"]=>
    array(2) {
    [1]=>
    string(35) "b1_f90a4fd19e2af97b9e7f49368bcdda71"
    [2]=>
    string(35) "b2_f90a4fd19e2af97b9e7f49368bcdda71"
    }
    ["language"]=>
    array(13) {
    ["mailer_not_supported"]=>
    string(25) " mailer is not supported."
    ["provide_address"]=>
    string(55) "You must provide at least one mailer is not supported."
    ["execute"]=>
    string(19) "Could not execute: "
    ["instantiate"]=>
    string(36) "Could not instantiate mail function."
    ["authenticate"]=>
    string(35) "SMTP Error: Could not authenticate."
    ["from_failed"]=>
    string(35) "The following From address failed: "
    ["data_not_accepted"]=>
    string(30) "SMTP Error: Data not accepted."
    ["recipients_failed"]=>
    string(56) "SMTP Error: The following SMTP Error: Data not accepted."
    ["connect_host"]=>
    string(43) "SMTP Error: Could not connect to SMTP host."
    ["file_access"]=>
    string(23) "Could not access file: "
    ["file_open"]=>
    string(33) "File Error: Could not open file: "
    ["encoding"]=>
    string(18) "Unknown encoding: "
    ["signing"]=>
    string(15) "Signing Error: "
    }
    ["error_count"]=>
    int(1)
    ["LE"]=>
    string(1) "
    "
    ["sign_cert_file"]=>
    string(0) ""
    ["sign_key_file"]=>
    string(0) ""
    ["sign_key_pass"]=>
    string(0) ""
    }

  2. Mike Challis
    Member
    Plugin Author

    Posted 4 years ago #

    Try using PHP mail function to send the mail instead of the WordPress
    mail function.
    On the plugin settings page you will find this setting: "Send E-mail
    function:", try setting this to "PHP", then test the form again. In some
    cases, this will resolve the problem.

    Did it work?

  3. kcjson15
    Member
    Posted 4 years ago #

    In the contact form settings or the wp-mail?

  4. kcjson15
    Member
    Posted 4 years ago #

    I changed the setting in wp-mail and received the same error. After changing to the php setting in the contact form settings I received the following error ON the site:

    Warning: mail() [function.mail]: SMTP server response: 451 See http://pobox.com/~djb/docs/smtplf.html. in D:\Hosting\2716753\html\abe\wp-content\plugins\si-contact-form\si-contact-form-process.php on line 364

  5. Mike Challis
    Member
    Plugin Author

    Posted 4 years ago #

    Not all mail sending problems have the same cause.
    Please contact me here for support:
    http://www.642weather.com/weather/wxblog/support/

  6. kcjson15
    Member
    Posted 4 years ago #

    I solved this by switching to a Lunix server. I read posts about it being more cooperative with wordpress. I use godaddy hosting.

    After the switch, the form worked on every page with the exception of the index. This was resolved by removing all the default godaddy files that were placed (by godaddy) on the index page of file manager.

    Very happy.
    Now I sleep.

  7. beckyddesign
    Member
    Posted 3 years ago #

    Changing the Send E-mail function: to PHP did the trick for me. Love this form Mike, will be donating soon, it's the only one that I've gotten to work in WP reliably! Thanks

  8. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    More info for anybody else...

    Some servers require special settings before mail will send, they are setup this way to help prevent spam.
    My plugin has settings you can use to try to fix mail delivery problems, see this FAQ for help:
    Try step 4.
    http://wordpress.org/extend/plugins/si-contact-form/faq/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic