WordPress.org

Ready to get started?Download WordPress

Forums

FancyBox for WordPress
[resolved] Stopped working with wordpress 3.3 and plugin 3.0 update (30 posts)

  1. slimsnakey
    Member
    Posted 2 years ago #

    The plugin has stopped working with latest update. Restoring to previous version it works. I have added this in http://www.incarz.com/
    but it stopped working after update. So i have changed it to other plugin.

    http://wordpress.org/extend/plugins/fancybox-for-wordpress/

  2. Theodas
    Member
    Posted 2 years ago #

    I'm having the same issue with all my sites running 3.3 and this plugin :/

  3. yukoner
    Member
    Posted 2 years ago #

    Same thing here as well. It was working OK with WordPress 3.3 until this morning's update to version version 3.0 of this plugin.

    I have gone back to 2.7.5 for now and it is working fine.

    Norm

  4. Carla Izumi Bamford
    Member
    Posted 2 years ago #

    Same here, version 3.0 didn't work for me.

  5. B1gJ4k3
    Member
    Posted 2 years ago #

    Ditto for me. Luckily I had tested things out on my local version before pushing anything live...

  6. Theodas
    Member
    Posted 2 years ago #

    The reset defaults fixed it for me.

  7. yukoner
    Member
    Posted 2 years ago #

    @Theodas
    Where do I find the "reset defaults" please?
    I am looking in the previous version before I try the update again and am unable to locate it.

    Norm

  8. B1gJ4k3
    Member
    Posted 2 years ago #

    OK, yeah. Resetting defaults on the admin page did it for me. It's under Settings > Fancybox for WP. It's the button right under the blue save changes.

  9. yukoner
    Member
    Posted 2 years ago #

    Thanks everyone, resetting the defaults has worked for me as well.
    Norm

  10. Roger Soto
    Member
    Posted 2 years ago #

    Gracias..!!! </br> a mi me funciono reseteando y salvando las opciones

  11. Delete Me
    Member
    Posted 2 years ago #

    The upgrade doesn't carry over the old settings. Be nice if this was mentioned in the changelog.

  12. clunkified
    Member
    Posted 2 years ago #

    3.0 plugin upgrade with WP 3.3 broke.

    Reset plugin back to defaults as mentioned in this thread.

    Now it works.

  13. lizzmo
    Member
    Posted 2 years ago #

    Thanks, resetting worked for me too.

  14. tyler_durdin
    Member
    Posted 2 years ago #

    I don't see what you guys are talking about

    inside fancybox for wordpress on the info tab

    below the save changes blue button are three boxes one of which is the developer asking for beer <_>

  15. José Pardilla
    Member
    Plugin Author

    Posted 2 years ago #

    The setting bug should be fixed now, if you remove and reinstal the plugin it should work now.

    If you prefer you can revert the settings the revert button is only available from version 3.0.0 and on).

  16. billboc
    Member
    Posted 2 years ago #

    i can't go no more to the settings page since the update !
    and
    the link to go to the settings disappeared !
    help please
    thank you

  17. Michael
    Member
    Posted 2 years ago #

    I am in the same situation as billboc. On my WordPress 3.2.1 multisite network, the Fancybox for WP link under the Settings menu has disappeared from all sites.

    Trying to access the URL directly gives me the error:
    "You do not have sufficient permissions to access this page."
    /wp-admin/options-general.php?page=fancybox-for-wordpress

    If I revert back to 2.7.5, I can see the menu again, but I have lost my settings.

    I retried the download with the minor changes (corrected version number and red "Note:" on the settings page), but it still did not work.

  18. tyler_durdin
    Member
    Posted 2 years ago #

    What new features are there with this version anyway? I can't find anything?

  19. José Pardilla
    Member
    Plugin Author

    Posted 2 years ago #

    Billboc, Michael,

    If you both run the plugin on a multisite installation the problem might be related to a change i made in user roles while updated old code.

    I will try to fix this today in 3.0.1

    tyler_durdin,

    The latest version comes with new effects and options from fancybox 1.3.4 as well as improved javascript and php code in many areas.

    If the 2.7.5 version is enough for you, you may not notice much, but in my server it wasn't behaving correctly in WP3.3, the menu showed a php notice and crashed when saving options.

  20. billboc
    Member
    Posted 2 years ago #

    thank you !

    - i am not on a multisite installation but the problem is the user roles too
    - the plugin works very well even if i can't go to the settings ;-)
    - thank you for your quick answer

    we are now waiting for the next update !
    regards

  21. Kristina
    Member
    Posted 2 years ago #

    I have Thesis theme and the plugin doesn't work on my site--it's not inserting the attributes to make fancybox work on clicked images, etc. This is the first time I've installed the plugin on my site, and hitting 'reset defaults' unfortunately didn't work.

    Will be uninstalling. Would love if it was compatible with Thesis.

  22. billboc
    Member
    Posted 2 years ago #

    it works fine now !! thank you for the last update !!

  23. Michael
    Member
    Posted 2 years ago #

    With the 3.0.1 update, I can now see the Fancybox for WP settings option on all sites. Thanks.

  24. tinkererguy
    Member
    Posted 2 years ago #

    3.0.1 was working (after resetting to defaults) for about a week, on WordPress 3.3, but it's now failed again. Can't find any other conflicting Plugin that could explain this.

    Unfortunately, this time, resetting to defaults didn't help. Deactivating, Deleting, then Adding, then Activating the plugin again didn't help either.

    Sounds like going back to 2.7.5 is the way to handle the wait until a fix is found.

  25. pborges
    Member
    Posted 2 years ago #

    yes, resetting just fixed the problems I was having. :)

  26. tinkererguy
    Member
    Posted 2 years ago #

    Hmm, "Revert to defaults" didn't work, deactivating, uninstalling, going back to 2.7.5 didn't work. Then deactivated, uninstalled, then went to 3.0.1 again, that didn't didn't work, I'm outta luck. Hoping for a fix, perhaps 3.0.2 is coming soon? Any known conflicts with other Plugins? I don't have any other Plugins installed that use jQuery.

  27. tinkererguy
    Member
    Posted 2 years ago #

    Found the culprit.
    I went into my site's filesystem, sorting the /plugins directory by date of folder creation, narrowing it down to only 2 recently installed plugins.

    "WordPress Table of Contents Plugin" version 1.1:
    http://rastider.com/wordpress-table-of-contents-plugin
    is apparently incompatible with FancyBox, yep, it uses jquery (see above site for details).

    As soon as I deactivated WordPress Table of Contents, making no other changes at all, FancyBox 3.0.1 immediately began working just fine again.

  28. José Pardilla
    Member
    Plugin Author

    Posted 2 years ago #

    Hi tinkererguy,

    Glad that fixed it. Just to clarify though, plugins that use jQuery are not by definition incompatible with Fancybox for WordPress, the problem arises only when a plugin loads jQuery on it's own instead of using WordPress functions to do it, causing jQuery to load twice and break things. :)

  29. tinkererguy
    Member
    Posted 2 years ago #

    Got great clarification that I'd like to share, since my post above implies the very presence of jquery broke things, and that's not the case:

    ...plugins that use jQuery are not by definition incompatible with Fancybox for WordPress, the problem arises only when a plugin loads jQuery on it's own instead of using WordPress functions to do it, causing jQuery to load twice and break things...

  30. seagrass
    Member
    Posted 2 years ago #

    I'm REALLY new at wordpress, CSS, HTML, etc and was hoping Fancybox would be an easy, snazzy solution on my Thesis site. I updated to 3.3.1 today and installed Fancybox but it won't work. Is there something I'm missing?

    I'd like it to work on this page but I'm not sure if I need to add anything to my custom file editor to make it happen.

    http://www.seagrassstudio.snazzymustache.com/gallery-2/

    any help would be greatly appreciated. Oh - and how do I know if there's a plugin with jQuery that might prevent this from working?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic