WordPress.org

Ready to get started?Download WordPress

Forums

FancyBox for WordPress
[resolved] fancybox not working anymore (17 posts)

  1. ilium
    Member
    Posted 3 years ago #

    Hi, been trying to get fancybox to work on my blog. i'm using 3.1.1 and the berlin theme. my blog is http://2groove-concept.net/
    the problem is kind of weird. before i got my webhoster, i tried the 7 day trial there, installed wordpress, the theme and your plugin. everything worked fine.
    now that i rented the server, installed everything, the plugin won't work at all! i'm absolutely not familiar with html, php...i always google my problem and try to fix it somehow, but this time i just can't get around.

    i hope you can help me somehow.

    http://wordpress.org/extend/plugins/fancybox-for-wordpress/

  2. ilium
    Member
    Posted 3 years ago #

    forgot to mention, i'm using the WordPress Facebook Like Plugin, WordPress.com Stats, Contact Form 7 and WP Super Cache

  3. Spencer Hill
    Member
    Posted 3 years ago #

    Have you tried disabling all of the other plugins and then testing the FancyBox item in question?

  4. ilium
    Member
    Posted 3 years ago #

    that's the first i tried. :\

  5. ilium
    Member
    Posted 3 years ago #

    i also tried several other fancybox plugins. none worked. one messed the picture slider on the mainpage up. i guess thats due to some jquery problem, whatever that means. i also tried the options at the jquery options at the troubleshooting page. won't help.

  6. Spencer Hill
    Member
    Posted 3 years ago #

    I don't see anything unusual but I did notice there are a lot of JavaScripts in the code and that appears the be the most likely culprit. Unless the server you're on doesn't have JavaScript enabled/installed (which is extremely unlikely) it doesn't make sense to me that FancyBox would stop working.

    Sorry I can't be more helpful!

  7. Ben Casey
    Member
    Posted 3 years ago #

    can you point us to a page where it is supposed to be working? seeing a JS error might help :)

  8. ilium
    Member
    Posted 3 years ago #

    here is a page where it doesn't work. http://2groove-concept.net/karl-kollwitz/
    as you can see, it simply opens the picture on a new page instead of a fancybox.

  9. ashbryant
    Member
    Posted 3 years ago #

    Ours too has just stopped working, just noticed today.

    http://goo.gl/sPkHG

    Any ideas why?

  10. ilium
    Member
    Posted 3 years ago #

    ok i found out that if you click on an image it opens a new page with only the image. if you click THEN on the image, fancybox works. but it don't want that new page at all. if i remove the hyperlink from the image it can't click on the image at all and nothing happens.

    what can i do here?

  11. ilium
    Member
    Posted 3 years ago #

    nevermind. sorted everything out. finally. :)

  12. ilijusin
    Member
    Posted 3 years ago #

    Do you mind sharing how you solved it? I'm having a very similar problem.

  13. ashbryant
    Member
    Posted 3 years ago #

    For me, it turned out to be a conflit with another plugin that broke and then killed fancybox too.

  14. ilijusin
    Member
    Posted 3 years ago #

    Yep. Same here. I disabled W3 Total Cache plugin and it started working again.

  15. ilium
    Member
    Posted 3 years ago #

    sorry, i was so reliefed that i got it working that i totally forgot to mention my solution for the problem.

    the problem was the link url of the pictures. i had to select the a different link url option. i'm not sure what it was before, but after i selected the option to link the image directly to the webspace i got the plugin working, and it didn't open new pages for pictures anymore.

    if you edit a post, select visual, click the image, edit it and look at link url. that's where the problem came from.

    hope that helps.

  16. Secret345
    Member
    Posted 3 years ago #

    hm.. i have the same probs..
    the strange thing is that i change the setting which doestn shows titles.
    After that the plugin will not work. I checked the way which ilium explain but nothing.

    I have delete ist and install it new.. but nothing..
    hope u could help me

  17. Secret345
    Member
    Posted 3 years ago #

    ?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic