WordPress.org

Ready to get started?Download WordPress

Forums

Fancy Gallery
[resolved] Not Working (18 posts)

  1. deanlynn
    Member
    Posted 3 years ago #

    Hi,

    I have created a gallery in my post - http://deanlynn.com/pete/news/musicians-gallery/

    I installed your plugin Fancy Gallery did all the settings and saved clicked view post and the images still just link to themselves?

    Was wondering what the issue was and if there was something I am missing here?

    Thanks

    http://wordpress.org/extend/plugins/fancy-gallery/

  2. Dennis Hoppe
    Member
    Plugin Author

    Posted 3 years ago #

    The problem is the double inclusion of jQuery in your website.

  3. deanlynn
    Member
    Posted 3 years ago #

    What do i need to delete?

  4. Dennis Hoppe
    Member
    Plugin Author

    Posted 3 years ago #

  5. deanlynn
    Member
    Posted 3 years ago #

    humm that will effect my Feature slider.. might have to move to another plugin.

    Let me delete them both i see what your saying now..

  6. deanlynn
    Member
    Posted 3 years ago #

    Im going to need to remove the conflicting js with your plugin as i need the jquery to be used for a few plugins i have removed the slider one and used the default on the theme. Just need to remove fancy gallery one.

  7. deanlynn
    Member
    Posted 3 years ago #

    How do I get your plugin to run in noConflict?

    as I think this would solve the issue?

  8. ivanrazine
    Member
    Posted 3 years ago #

    Solved your problem:

    wp-content/plugins/coin-slider4-wp/coinslider-content.php

    >>>DELETE LINE 42

    Check my website: centrerussemons.net

    Works like a charm!!!

  9. ivanrazine
    Member
    Posted 3 years ago #

    You may also add this code to your functions.php :

    <?php
    function my_init_method() {
        if (!is_admin()) {
            wp_deregister_script( 'jquery' );
            wp_register_script( 'jquery', 'http://ajax.googleapis.com/ajax/libs/jquery/1.4/jquery.min.js');
            wp_enqueue_script( 'jquery' );
        }
    }    
    
    add_action('init', 'my_init_method');
    ?>
  10. deanlynn
    Member
    Posted 3 years ago #

    Hay Ivan,

    Thanks for the reply!

    I tried what you said still no joy!

  11. deanlynn
    Member
    Posted 3 years ago #

    When i take out
    <script type="text/javascript" src="<?php bloginfo('template_directory'); ?>/js/jquery-1.4.2.min.js"></script>

    from the header.php which i use for my navigation and menu... it works.

  12. ivanrazine
    Member
    Posted 3 years ago #

    So, when you take out this bit of code, your menu stops working?

  13. deanlynn
    Member
    Posted 3 years ago #

    yeah

  14. ivanrazine
    Member
    Posted 3 years ago #

    You have to make sure jQuery is only inserted once before any other code.

    I had the same problem, the same Firebug console error and I solved it by making sure no plugin inserted jQuery.

    If it doesn't help, you should probably write a cleaner menu code by yourself, here is my example: Demo

  15. deanlynn
    Member
    Posted 3 years ago #

    man I'm starting to pull out hairs.

    Its conflicting with my menu and slider now. why cant I just no conflict these plugins or developers do it they must know that we use jquery in other plguins.... =/ Sad Times!

  16. ivanrazine
    Member
    Posted 3 years ago #

    You insert jQuery 1.4.4 on line 17 and jQuery 1.4.2 on line 61.

    You also use too many plugins for what it's worth.

    For example, you don't need to use Cufon when you know how to use @font-face

  17. deanlynn
    Member
    Posted 3 years ago #

    Think I have fixed it!

    Mate whats your paypal email address will drop you a donation in a few days!

  18. ivanrazine
    Member
    Posted 3 years ago #

    I'm just glad you made it :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic