WordPress.org

Ready to get started?Download WordPress

Forums

Facebook
[resolved] Social Publisher Error: An error occurred with Scott Wyden Imagery (API). (16 posts)

  1. Andrew.Bloom
    Member
    Posted 1 year ago #

    When I go into the WordPress Facebook plugin settings (after I have created my Facebook app) and try to Link your Facebook account to your WordPress account to enable.

    This is the error I received:

    An error occurred with Scott Wyden Imagery (API). Please try again later.

    I noticed this issue was mentioned on other posts and updated to your dev version but I am still getting this error.

    Last night I easily setup this app on another website just fine, maybe this is happening due to a server setting, PHP version, or something else?

    Any suggestions?

    http://wordpress.org/extend/plugins/facebook/

  2. Scott Wyden Kivowitz
    Member
    Posted 1 year ago #

    Is it wrong of me to find it funny that Facebook hasn't fixed this silly problem yet?

  3. Andrew.Bloom
    Member
    Posted 1 year ago #

    I knew it! Scott Wyden is behind a FaceBook conspiracy to make all plugins not work with WordPress!

    Stop the presses!

  4. Scott Wyden Kivowitz
    Member
    Posted 1 year ago #

    HAHA - It's a cunning plot

  5. nikcree
    Member
    Posted 1 year ago #

    Scott has struck again on my site.

  6. bonnz
    Member
    Posted 1 year ago #

    On mine too .....

  7. Scott Wyden Kivowitz
    Member
    Posted 1 year ago #

    I feel bad Facebook can't get this figured out

  8. ThimGrim
    Member
    Posted 1 year ago #

    Lol, I have just installed this plugin and I'm having this error with "Scott". Good that Google works... I'm lucky.

  9. Scott Wyden Kivowitz
    Member
    Posted 1 year ago #

    I'm not sure Facebook is listening anymore

  10. Andrew.Bloom
    Member
    Posted 1 year ago #

    I've figured out how to fix this error.

    Apparently a very simple fix (for me and hopefully you too).

    All you need to do is go to:
    https://developers.facebook.com/apps/

    Find your app you created, click Edit Settings, and make sure that you have App on Facebook checked. Then enter your domain and a link to https:// (even if you don't have one, just enter it in).

    Then my plugin started working.

    Now, I do not remember the instructions telling you to do this. In fact it does not. If you see "nux_app_settings.png" and it does not show or say to do this:

    Step 2: Set up the App

    Next, set up your app so that it looks like the settings below. Make sure you set your app's icon and image, too. If you already have an app and skipped Step 1, you can view your app settings by going to https://developers.facebook.com/apps.

    Here are for some recommendations for filling this form out, based on where this plugin is installed.

    Once I do the plugin works. Also its worth mentioning to get the developer version from their GitHub, since it fixes some other problems (https://github.com/facebook/wordpress/).

    If you are still having issues, let me know. I'll try to recreate my steps for you.

  11. bonnz
    Member
    Posted 1 year ago #

    Hi Andrew,

    tried your thoughts but I stil habe the same issue.

  12. Samuel Wood (Otto)
    Tech Ninja
    Plugin Contributor

    Posted 1 year ago #

    @Andrew Bloom Thanks for your suggestion, but that isn't how the FB App works, and doing that really wouldn't fix the problem.

    The "App on Facebook" does not need to be checked to use the plugin, and in fact it probably should not be checked for most cases.

  13. Andrew.Bloom
    Member
    Posted 1 year ago #

    Must've been WPBook then.

    I was getting frustrated with this plugin so I installed WPBook and followed their instructions. It didn't work so re-enabled this plugin, and it magically starts working.

    Possibly the one step that could've mattered was Granting Permissions for the page. That step is missing in this plugin, but it probably does so automatically?

    Maybe that is why people are having issues?

    Sorry for my round-about way of explanation.

  14. bonnz
    Member
    Posted 1 year ago #

    http://www.getcomputerservices.co.uk/web-development/simple-facebook-connect-scott-wyden-imagery/

    This worked for me.

    You only have to deactivate it for the first authorization (Your galleries are still available after reactivation!). Post on your fan page works even with activated NextGen Gallery Plugin.

  15. Andrew.Bloom
    Member
    Posted 1 year ago #

    NextGen Gallery is the culprit, eh?

    I can't remember if I disabled that or not.

    Thanks for the info bonnz!

  16. Scott Wyden Kivowitz
    Member
    Posted 1 year ago #

    Turns out it is NextGEN Gallery - and the fix is in the works!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic