WordPress.org

Ready to get started?Download WordPress

Forums

Facebook
Publish to fan page setting Disabled (160 posts)

  1. mcitpsa
    Member
    Posted 1 year ago #

    I've got the same problems.
    Does anyone has a idea how to solve this issue?

  2. patv
    Member
    Posted 1 year ago #

    Is anyone logged onto facebook automatically (ie you don't log in everytime you hit their homepage) and experiencing this problem?

  3. ChristineFerguson
    Member
    Posted 1 year ago #

    I am. I stay logged in automatically using Google Chrome and I just posted an update that did not post to Facebook. It gave me the same error that's mentioned above.

  4. Zach Schnackel
    Member
    Posted 1 year ago #

    .

  5. Matt Kelly (Facebook)
    Member
    Plugin Contributor

    Posted 1 year ago #

    Hi folks, can one of you try the development version of the plugin on GitHub?

    Download it at https://github.com/facebook/wordpress/zipball/master. We think we've fixed the problem, but would like confirmation. Thanks!

  6. mcitpsa
    Member
    Posted 1 year ago #

    So i've got a interresting issue (sorry for my poor english)

    So i updated today my main blog to the new WordPress Version.
    After that, the FB Plugin said "publish on fanpage = disable"
    As i created a test blog post, the FB Plugin deployed the BlogPost on the FB Fanpage.
    On this time nobody was Logged on in facebook.
    After a logon to Facebook the FB Plugin also shows "publish on fanpage = disabled" and i can't select the FanPage.
    After a logoff in wordpress and a login in the wp-admin i can select the Facebook Fanpage.
    WTF?!?
    Now i'm really confused ...

  7. FIDImages
    Member
    Posted 1 year ago #

    Matt, is the "publish to Author's timeline" fix included in that version?

  8. Matt Kelly (Facebook)
    Member
    Plugin Contributor

    Posted 1 year ago #

    @FIDImages no, we're working on that. Task at https://github.com/facebook/wordpress/issues/197 (FYI @mcitpsa)

    Also, please stay on topic to the original issue, otherwise it makes it really hard for us to track these issues. If your comment isn't at all related to the original issue, please open a new thread. Thanks

  9. sscott721
    Member
    Posted 1 year ago #

    I downloaded the version from the link above, and nothing has changed. The dropdown menu still says disabled.

  10. Matthew Hui
    Member
    Plugin Contributor

    Posted 1 year ago #

    Does the problem only come up after logout or does the setting reset to 'disabled' by itself?

  11. jonradio
    Member
    Posted 1 year ago #

    I, too, downloaded the development version that Matt offered in his second to last post. So far, it appears to be working properly, without the Disabled issue, but I still need to create a WordPress Post to see that triggers Disabled status, as the previous version did.

  12. jonradio
    Member
    Posted 1 year ago #

    So far, I'm getting the following message for each attempt by the plugin to post on FaceBook:

    Failed posting to rwcrn.com: Radio West / Canadian Radio News's Timeline because the access token expired. To reactivate publishing, visit the Facebook settings page and re-enable the "Publish to fan page" setting. Full error: {"message":"Error validating access token: Session has expired at unix time 1343782800. The current unix time is 1343783691.","type":"OAuthException"}

    The odd thing is that sometimes it works and sometimes it doesn't. The only consistent thing, other than getting the error message on every post attempt, is that when it actually does successfully make the post on Facebook, the plugin does NOT go into disable state.

  13. mcitpsa
    Member
    Posted 1 year ago #

    Bahhhh ....
    since yesterday the plugin still working ...
    Today its working for some hours.
    Now we want to publish some posts and .. .tada ....
    Failed posting to wenzel.tk's Timeline because the access token expired. To reactivate publishing, visit the Facebook settings page and re-enable the "Publish to fan page" setting. Full error: {"message":"Error validating access token: Session has expired at unix time 1343772000. The current unix time is 1343806955.","type":"OAuthException"}

    *knarf* or let's say with the words of Homer "No" ...

  14. mcitpsa
    Member
    Posted 1 year ago #

    Wow some news from my "investigation" ...

    It seems that the Plugin cant be used in a network with a enabled proxy.
    I was today on a location with a proxy enable and facebook.com are blocked.
    First Time i can "deploy" only one post.
    After this the second Post will failed.
    ...
    Hmm i'll try it tomorrow on my own office with my Proxyserver...

  15. Farm Fresh Miami
    Member
    Posted 1 year ago #

    Hi there, I used the file on this link
    Download it at https://github.com/facebook/wordpress/zipball/master. We think we've fixed the problem, but would like confirmation. Thanks!

    BUT that did'nt solve the problem for me.
    Thanks

  16. RickieLindley
    Member
    Posted 1 year ago #

    Howdy,
    Same problem here, but I manage a page for a band and they need to have the abliity for 4 different people to make these linked post.

    So I either need a way for it to post no matter of what is going on with facebook and who you are loged in as OR… the ability to have multiple people setup for posting.

  17. lindaloustarr
    Member
    Posted 1 year ago #

    I'm having the same problem & also just added this plugin to my main site & lindaloustarr.com main fan page lindalou starr set everything up correctly - have published twice from pages twice from posts they're all showing on my timeline but the submit app in open graph keeps telling me this:

    Publish Actions
    You must publish at least one action to your Timeline using this action type. Review the documentation.

    It's also pulling a picture into those pages & posts from somewhere else in my site . . . that isn't even relative . . . ??????

    Ok Matt, uploaded the developer plugin you suggested haven't seen the disabled button change yet & have published 6 times now & still can't get past the submit action types - it's still saying I have to one action? So I'm just going to keep on keepin' on with this until we hear from you, hopefully in this post that things have been fixed :)

    Have a peaceful & blessed weekend :)
    Linda Lou

  18. Punkjahh
    Member
    Posted 1 year ago #

    Hello, I just want to report I'm also experiencing this issue.

  19. nicolerific
    Member
    Posted 1 year ago #

    I also uploaded the developer version of the plugin, installed it, deactivated the original plugin and activated the developer one. Unchecked the social publisher box, saved settings, then re-checked it to see if I could set Publish to Fan Page as enabled. Still no luck. Please let me know if there are any new fixes, for now I am unable to publish to my author timeline and my fan page.

  20. iamright2000
    Member
    Posted 1 year ago #

    I am also having the same issue. i noticed I was on my clients FB fan page, switch over to my profile. Did a new wordpress post, and the token error come up. I was able to duplicate the error on my own site.

    I am unable to get it enabled again.

    Please update this plugin soon! My clients will sooooo appreciate it.

  21. black lion
    Member
    Posted 1 year ago #

    Well the old is going into the Carbidge Trunk.
    The NEW one I wahas testing give the same problems.
    The first 5 post went to my Newspaper on FB and to my time line. After the 5th post it went down.
    Now for every post I have to activate the newspaper and change the post to concepts. Then change the concept after re-write (bijwerken) to publish. Hit the publish buttom and get after a wile the same error.

    This is NOT WORKING.
    I use WP 3.4.1 and the new Facebook plugin form github ??

    This one is going to the Carbidge Trunk also. I stop fighting this plugin.

  22. beechclemo
    Member
    Posted 1 year ago #

    Hi All,

    Also experiencing the same issue with "Publish to Fan Page" reverting to disabled after a couple of posts.

    Is there a fix yet?

    Great Plugin by the way, just hope this gets fixed, then its perfect!

    Rob

  23. Matthew Hui
    Member
    Plugin Contributor

    Posted 1 year ago #

    Try the new version on github. It's updated pretty frequently

  24. sgatz
    Member
    Posted 1 year ago #

    Rishi & Matt Kelley,

    The development version off GitHub fixed the issue for us and posts all seem to be going through ok. Will report back with any change, but it seems to do the duty.

  25. black lion
    Member
    Posted 1 year ago #

    @sgatz; I had that one too. Also the same problem and also into the carbich-trunk

  26. lindaloustarr
    Member
    Posted 1 year ago #

    Where do you find it on github? what's the url?
    Thank you :)

  27. cloakey
    Member
    Posted 1 year ago #

    Same issue here guys, this is an otherwise brilliant plugin..

  28. black lion
    Member
    Posted 1 year ago #

    @Linda....; go to the top by fresh..... There it is. But still not working.

  29. lindaloustarr
    Member
    Posted 1 year ago #

    Thanks black lion - I've never been to github before so am at front page click on explore - https://github.com/explore - then what LOL guess it doesn't matter if it's still not working but would be nice to know how to use the resource :)
    LL

  30. Matthew Hui
    Member
    Plugin Contributor

    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic