WordPress.org

Ready to get started?Download WordPress

Forums

126

Facebook
Publish to fan page setting Disabled (160 posts)

  1. TammyM
    Member
    Posted 2 years ago #

    Updated to version 1.0.2 this morning and the publish to fan page option is now Disabled. I saved the app settings again on my Facebook account and was able to view the available fan pages, select the one I wanted and save the plugin settings.

    The problem comes when I log out of my Facebook account. The plugin settings revert back to Disabled for the publish to fan page option.

    http://wordpress.org/extend/plugins/facebook/

  2. Matt Kelly (Facebook)
    Member
    Plugin Contributor

    Posted 2 years ago #

    @TammyM: thanks for the report, we'll take a look.

  3. vampyregod
    Member
    Posted 2 years ago #

    Same problem. I can change it to a fan page, but it seems after a post or two it reverts back to disabled.

  4. haneefputtur
    Member
    Posted 2 years ago #

    I too face the same problem. It works for 5-6 posts , then it gets disabled. I am using this plugin in a Multi-Site environment.

    If I want re-enable it I should login to my facebook and refresh the facebook plugin settings side by side , then it will start working for sometime.

  5. deepfunk
    Member
    Posted 2 years ago #

    Same problem

    WordPress 3.4.1

    FB plugin 1.0.2

  6. Matt A
    Member
    Posted 2 years ago #

    I have this problem as well. 3.4.1 and FB 1.0.2

    Things were good at first when I was testing the first FB app I created, but then I created a 2nd FB app for 'production", and now the plugin won't allow me to authorize the new app w/ FB - and I also don't get to select a fanpage. All 3 passwords are in correctly, but for the Fanpage options I just get 'disabled'.

  7. jianghawk
    Member
    Posted 2 years ago #

    Exact same problem here...

    Used to be able to publish my post to Fan page automatically, now it is "Disabled" and no other options. Please fix this ASAP as it's very important for me to post to Fan page automatically, versus manually.

  8. 6Ril_fr
    Member
    Posted 2 years ago #

    Same problem for me...

  9. Matt A
    Member
    Posted 2 years ago #

    This has been a bummer; I've never tinkered with a plugin this long. Can't wait for it to work though, because I really like what it *wants* to do.

    Installed it for a 2nd site & it does the job, but sometimes it gives an error at time of posting - even when it posts to a fanpage correctly. Error says that it has failed to post to my personal timeline - even though I never asked it to. Also, for a text posting it grabs an image out of my media library & I have no control over this (ironically in this case, it grabs a Google+ icon, so I can't realistically use the plugin until I can get it to stop doing this).

    What I've figured now from installing this plugin for 2 sites is that you get a somewhat functional plugin - unless you delete the first FB app you've created. If you do that and create a 2nd FB app and add the 3 associated passwords to the plugin & start over - you won't ever get anything but the 'Disabled" option when you want to select a fanpage,

  10. drachenzauberei
    Member
    Posted 2 years ago #

  11. mulegoat
    Member
    Posted 2 years ago #

    Same problem here

  12. Dustin Dauncey
    Member
    Posted 2 years ago #

    So what do we do then? Can we downgrade to the version that this was working in? I'm glad to know it's only this version - I just installed it and found this issue and was like WTH ahaha, but I'm glad to see I'm not the only one and that Facebook is also working on it, presumably quickly.

  13. LocalLics
    Member
    Posted 2 years ago #

    Same issue here with my site... can we get this plugin right?

  14. FIDImages
    Member
    Posted 2 years ago #

    Same issue on my site too.

  15. willsloan
    Member
    Posted 2 years ago #

    Count me in. This is frustrating to see it's been reported for several days now without a fix from the developer.

  16. loisleen
    Member
    Posted 2 years ago #

    Same problem here!

  17. Zach Schnackel
    Member
    Posted 2 years ago #

    Not that you guys/gals need another +1... but +1 here as well. Thanks!

  18. ChristineFerguson
    Member
    Posted 2 years ago #

    I'm having a similar problem. My "Publish to Fan Page" option has never worked until JUST NOW when I tried to make a test post so that I could copy and paste the error message I'm receiving. Usually it says it can't post to my fan page because the option has been disabled and it asks me to re-enable it.

    Also, the plugin posts to my personal timeline (or posts on the 'author' timeline) but I do not have that option selected and don't want it to post on my personal timeline. I have no idea why it's doing that.

  19. patv
    Member
    Posted 2 years ago #

    I'm having the same issue, here's the error messages I get:

    Failed posting to Physics CrossFit's Timeline because the access token expired. To reactivate publishing, visit the Facebook settings page and re-enable the "Publish to fan page" setting. Full error: {"message":"Error validating access token: The session is invalid because the user logged out.","type":"OAuthException"

    Debug:
    {"appid":"402202813150236","version":"1.0.2","domain":"physicscrossfit.com","social_publisher":{"enabled":"true","publish_to_fan_page":[],"mentions_position":"both"},"recommendations_bar":{"trigger":"50","read_time":"20","action":"like","side":"right","show_on":"all posts and pages"},"subscribe":{"layout":"standard","width":"250","colorscheme":"light","font":"arial","position":"both","show_on":"all posts and pages"},"comments":{"num_posts":"20","width":"470","colorscheme":"light","show_on":"all posts and pages"},"send":{"colorscheme":"light","font":"arial","position":"both","show_on":"all posts and pages"},"wp_ver":"3.4"}

  20. supakat111
    Member
    Posted 2 years ago #

    same problem

  21. ccharlot
    Member
    Posted 2 years ago #

    I also have this problem.

    If I enable the "post to fan page" and make a test just after that, it's OK...

    But if a few meinutes later another author post a message on the blog, the options get diabled... and without any error message :(

  22. haneefputtur
    Member
    Posted 2 years ago #

    I am just wondering will there be any use of waiting for the response from the developer or better to go ahead with other plugins?
    Till now no one from dev team confirmed about this issue.

  23. ccharlot
    Member
    Posted 2 years ago #

    It seems that I need to be connected to facebook with my browser to be able to post to my fan page.

    If someone else posts an article, the "post to fan page" gets disabled.

    This is a major BUG for this plugin, I'll ave to revert to Wordbooker or something else.. :(

  24. patv
    Member
    Posted 2 years ago #

    Yes, you must be logged into your Facebook account through your browser in order to post. Just like using the Graph API, you need to get an access token for Facebook to allow you to push content to their servers, and that token gets generated by logging in.

    I agree it is a pain when you're trying to deliver this plugin to customers, where you can't do any setup for them without almost connecting to Facebook as them.

  25. ChristineFerguson
    Member
    Posted 2 years ago #

    I remain logged into Facebook and I'm still having issues. I wish I knew what's wrong. This plugin is GREAT in theory.

  26. sturtos
    Member
    Posted 2 years ago #

    Same problem with the publish to page being disabled.

  27. Rishi Gharpuray
    Member
    Plugin Contributor

    Posted 2 years ago #

    This issue has been resolved since the release of 1.0.2. It is now available on github (https://github.com/facebook/wordpress). If you pull the newest version, and the issue still persists, don't hesitate to let us know!

  28. jonradio
    Member
    Posted 2 years ago #

    I count at least three posters in this thread who are experiencing the "Disabled Problem" with Version 1.0.2 of the plugin. And I can add myself to that list.

  29. Dustin Dauncey
    Member
    Posted 2 years ago #

    Yeah Rishi, this problem is definitely stemming from the 1.0.2 version from the sounds of it. Or at least many of the users on here are using that version and complaining of the problem. This version did not fix the issue, in fact from what I can tell it was the version that introduced this issue.

  30. FIDImages
    Member
    Posted 2 years ago #

    When we can expect a bug fix for that issue?

126

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic