WordPress.org

Ready to get started?Download WordPress

Forums

Facebook
[resolved] PHP Warnings? (5 posts)

  1. ecsouza
    Member
    Posted 2 years ago #

    This looks awesome ... I installed it and on my site (http://www.ericsouza.com) I am getting errors in the header and footer in both Firefox and Chrome ... is this because maybe Facebook hasn't propagated the new app yet?

    In the header I am getting these errors ...

    Warning: session_start() [function.session-start]: open(/home/content/s/y/d/sydfin/html/sessions/(*app secret*)02, O_RDWR) failed: No such file or directory (2) in /home/content/s/y/d/sydfin/html/ericsouza/wp-content/plugins/facebook/includes/facebook-php-sdk/facebook.php on line 39

    Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/content/s/y/d/sydfin/html/ericsouza/wp-content/plugins/facebook/includes/facebook-php-sdk/facebook.php:39) in /home/content/s/y/d/sydfin/html/ericsouza/wp-content/plugins/facebook/includes/facebook-php-sdk/facebook.php on line 39

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/content/s/y/d/sydfin/html/ericsouza/wp-content/plugins/facebook/includes/facebook-php-sdk/facebook.php:39) in /home/content/s/y/d/sydfin/html/ericsouza/wp-content/plugins/facebook/includes/facebook-php-sdk/facebook.php on line 39

    In the footer, I'm getting these ...

    Warning: Unknown: open(/home/content/s/y/d/sydfin/html/sessions/sess_17214a865be4a85fb19b7e00c9cae900, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/home/content/s/y/d/sydfin/html/sessions) in Unknown on line 0

    http://wordpress.org/extend/plugins/facebook/

  2. Christopher
    Member
    Posted 2 years ago #

    I am getting the exact same error(s). It worked fine under GoDaddy's Windows Ultimate. I migrated to GoDaddy's Linux Ultimate and everything still worked fine. However, I just migrated to GoDaddy's Linuz Ultimate 4GH and now I receive these errors whenever an App has been configured for the plugin (if I remove the App (i.e. blank out the fields and press update) the error goes away).

    Errors:

    Warning: session_start() [function.session-start]: open(/var/chroot/home/content/51/3319651/tmp/sess_h778cqmkebgl26o0ic7f2l8e31, O_RDWR) failed: No such file or directory (2) in /home/content/51/3319651/html/ChristopherFulghamCOM/wp-content/plugins/facebook/includes/facebook-php-sdk/facebook.php on line 39

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/content/51/3319651/html/ChristopherFulghamCOM/wp-content/plugins/facebook/includes/facebook-php-sdk/facebook.php:39) in /home/content/51/3319651/html/ChristopherFulghamCOM/wp-content/plugins/facebook/includes/facebook-php-sdk/facebook.php on line 39

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/51/3319651/html/ChristopherFulghamCOM/wp-content/plugins/facebook/includes/facebook-php-sdk/facebook.php:39) in /home/content/51/3319651/html/ChristopherFulghamCOM/wp-includes/pluggable.php on line 881

    Warning: Unknown: open(/var/chroot/home/content/51/3319651/tmp/sess_h778cqmkebgl26o0ic7f2l8e31, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0

  3. Samuel Wood (Otto)
    Tech Ninja
    Plugin Contributor

    Posted 2 years ago #

    The session start errors happen because your server's "temp" directories are not configured properly. Happens to the best of us. Happened to me too on GoDaddy hosting.

    Unfortunately, the only way to fix the problem is to ask your host why the tmp directory isn't working or setup properly for PHP sessions.

    One workaround is to set the session.save_path to an empty directory you control. How you do this is up to the webhost and such. It may be enough to create a tmp directory in your account and then use this line in the .htaccess to set the directory:

    php_value session.save_path '/path/to/a/writeable/folder'

    Alternately, you can try making a php.ini, but few hosts allow that.

  4. Christopher
    Member
    Posted 2 years ago #

    Thanks Otto.

    I am on the phone with GoDaddy tech support as I write this. They identified the problem just as you have and have already created the tmp directory in the appropriate place and all is working now.

    Thanks for your help.

  5. debdbuck
    Member
    Posted 1 year ago #

    I had the same problem! Thank you so much for the solution Otto!

    GoDaddy went through the "it's not our fault, it's the application's fault" rounds... I insisted that we check things out quoting this thread!

    After a hold time to "check with their advanced server team," the rep informed me that "the connection to the tmp folder was broken" during the migration from Windows to Linux.

    I kept him on the line until I put my app id and key in. It works!
    Thanks guys!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags