WordPress.org

Ready to get started?Download WordPress

Forums

Facebook Page Publish
Not posting to facebook (20 posts)

  1. peerless155
    Member
    Posted 2 years ago #

    I believe I've followed all of the setup instructions, have no errors listed on my plugin settings page, however, when I try to submit a new post, I get the following error and no version of my post appears on facebook:

    Facebook returned an unexpected error: (#240) Requires a valid user is specified (either via the session or via the API parameter for specifying the user.
    Try to resolve this issue, update the plugin or inform the author about the problem.
    [Error occured at line 347]

    Thoughts?

    http://wordpress.org/extend/plugins/facebook-page-publish/

  2. mtschirs
    Member
    Plugin Author

    Posted 2 years ago #

    Hi peerless155,

    Sorry for the wait. Does this error still bother you? If so, could you post me a link to your blog?

  3. peerless155
    Member
    Posted 2 years ago #

    yes, we still get this error when the plugin is activated. We are currently running without the plugin activated here on a custom WordPress install (latest): http://www.culinaryvagabond.com

    Theme in use, Graphene: http://www.khairul-syahir.com/wordpress-dev/graphene-theme

    Any help would be appreciated

  4. mtschirs
    Member
    Plugin Author

    Posted 2 years ago #

    I experimented a bit and think I found the cause for your problem: You can only publish to FB pages/profiles that have the same owner/admin as the FB application. If you try to publish to another page/profile, you get this forementioned error 240 since your application is not authorized to post there. The owner/admin of this page/profile would have to grant access rights to your application.

    Easiest solution: Only choose from those pages/profiles listed on the plugin configuration page.

  5. Luciano
    Member
    Posted 2 years ago #

    Same problem, I'm the admin of the page where I want to publish, all the set of the plugin are OK, the page is listed in the conf. page, but I'm receiving the error.
    theme 20/11, WP3.4.1

  6. roxchou
    Member
    Posted 2 years ago #

    Same here. I'm the admin of the page I publish to and everything worked fine until today. Plugin published correctly since I installed it a while back and every day for the past week. Today I get the same error as mtschirs:

    Facebook returned an unexpected error: (#240) Requires a valid user is specified (either via the session or via the API parameter for specifying the user.
    Try to resolve this issue, update the plugin or inform the author about the problem.
    [Error occured at line 347]

    I checked the plugin settings and everything is configured correctly...nothing was changed from the initial setting.

  7. roxchou
    Member
    Posted 2 years ago #

    Okay I figured what the problem is. Facebook recently added a "Voice" tab where you can post, comment and like as the admin of the page (for example Charity4You) or as yourself (Tina Smith). If you are logged in Facebook and you have checked to post as yourself (Tina Smith), the publish plugin errors, but if you switch to "Voice" as Admin of the page (Charity4You) then it publishes successfully.

  8. Luciano
    Member
    Posted 2 years ago #

    Ohps, I have many pages, do you mean that I have to switch each time I publish an article from a site of mine? I have several sites, each one with his own related page on fb, it would be really a problem for me to go to fb, change identity, then publish, and repeat all the cycle each time.

  9. couponingwithboys
    Member
    Posted 2 years ago #

    I have it set to publish as my page, still getting the error. I went in and reset my Secret Key and everything to see if that would fix it, still nothing. The "Voice" tab started last week, my plugin worked fine until today, it was working at 3am EST, but when I tried to post at 12:30, it threw up the error.

  10. Luciano
    Member
    Posted 2 years ago #

    Same situation: I have it set to publish as my page, still getting the error. I have published manually as myself with another plugin without any problem. But automatically I have the same problem with this other plugin.

  11. roxchou
    Member
    Posted 2 years ago #

    For me it worked when I switched from my personal profile to the admin profile in the Voice tab.

    Until today I didn't have any issues either. Maybe the author can look into this and shed some light!

  12. traypup
    Member
    Posted 2 years ago #

    I've got issues on all of my sites using this plugin as well:

    on wp v. 3.4.1, when I hit "grant access", I get the following error:

    Some or all access permissions are missing. Please click the button Grant access rights! and authorize the plugin to post to your Facebook profile or page.
    [Error occured at line 774]

    Your page or profile's access permissions could not be verified.

    on a site that's using v. 3.4, I've got this error (but somehow the post appeared on my FB page anyway):
    https://skitch.com/traypup/ersda/facebook-page-publish-options-tracey-kazimir-cree-wordpress

    Are there going to be any updates to this plugin soon? Please let us know so we can move on if you don't plan to update. Thanks!

  13. Luciano
    Member
    Posted 2 years ago #

    The plugin is working perfectly in a wp installation on an other host. It's possible that the solution to the problem has to be searched in the server configurations. Maybe facebook did changes that require different setup in php or whatever.

  14. jmtucu
    Member
    Posted 2 years ago #

    Same problem here

    Diagnosis.php says:

    There seems to be a problem
    
    Try enabling the compatibility options of the plugin
    
    WP_Error Object
    (
        [errors] => Array
            (
                [http_request_failed] => Array
                    (
                        [0] => SSL certificate problem: unable to get local issuer certificate
                    )
    
            )
    
        [error_data] => Array
            (
            )
    
    )

    The SSL module in the server works well.

  15. jmtucu
    Member
    Posted 2 years ago #

    If you check the "Ignore SSL certificate" it work fine.

  16. Luciano
    Member
    Posted 2 years ago #

    If you check the "Ignore SSL certificate" it work fine.

    It doesn't work in my installation

  17. tcgmsf
    Member
    Posted 2 years ago #

    Same problem, doesn't matter if "Ignore SSL" is clicked.

  18. Luciano
    Member
    Posted 2 years ago #

    Same problem, doesn't matter if "Ignore SSL" is clicked.

    Yes is true. I have the plugin already installed since long time on other sites on the same host that is working well and without problems.
    The problem mentioned in this thread seem to regard only the sites where I have installed the plugin recently, about a week - ten days ago.

    It seems that the problem happened 9 months ago, I suppose that it was solved and reappeared again in these days.

  19. werdplae
    Member
    Posted 2 years ago #

    I found out what was going on with this as per this page --> https://developers.facebook.com/bugs/465563203461606?browse=search_4ffb49f634ff91581497486

    All it is saying is that the pages have a new feature called "Voice", when you VISIT A PAGE you are an admin of, NOT SWITCHING TO THE PAGE, you will see a blue bar at the top that says "You are poting, commenting, and liking as [name of page] — Change to [Your personal profile].

    If you set the voice to your personal page you will get the #240 error. Change it back to the page, refresh your WP dashboard and *poof*, error's gone.

    That's what the "Requires valid user" in the error message is referring to. :)

  20. Luciano
    Member
    Posted 2 years ago #

    This worked for several my sites.
    The "voice" tab appearead today on my fb pages. Mayby in Italy things come later thai in US... :-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic