WordPress.org

Ready to get started?Download WordPress

Forums

Facebook Page Publish
"Grant Access Rights!" button leads to "no permission (3 posts)

  1. cinema5D
    Member
    Posted 2 years ago #

    Hi,
    After the facebook plugin stopped working lately I managed to get it to work via the suggested code change mentioned here

    However, I'm now stuck, because the plugin wants me to "grant access rights!" again. Whenever I click that button wordpress takes me to a page that says "You do not have sufficient permissions to access this page.".
    I know this page. I got there when wordpress wanted to change something internally but my folder was owned by the root user. Now the correct folders are owned by the server and I even tried making all files and folders owned by the server. I can edit theme code from within the wordpress, this should prove that the permission are there, right? So why am I seeing this page and what can I do to grant the rights to facebook again so my posts appear on the wall again.

    Thanks so much for any help.
    Sebastian

    http://wordpress.org/extend/plugins/facebook-page-publish/

    PS: The user has the write and execute permissions on all the files...

  2. Kuba Mikita
    Member
    Posted 2 years ago #

    You dont have to change any files.
    I've got better and safer solution:

    You must go to edit site of your page: https://developers.facebook.com/apps/XXX_APP_ID_XXX/summary/
    Then on the left bookmark: Advanced and search the option in Migration called "Deprecate offline access". Turn if off.
    Now go to plugin settings, push again grant button and... enjoy plugin! :)

    I hope that helped

    Dla czytelników z Polski napisałem tutorial jak zainstalować wtyczkę krok po kroku wraz z opisem jak bezpiecznie naprawić ten błąd http://odpowiedznato.pl/jak-automatycznie-eksportowac-posty-z-wordpress-do-facebook/

  3. cinema5D
    Member
    Posted 2 years ago #

    Hi,
    Thank you very much for your answer. Unfortunately the setting "Deprecate offline access" had already been turned off...
    Still doesn't work.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic