WordPress.org

Ready to get started?Download WordPress

Forums

Facebook
[resolved] Object at URL ... of type 'article' is invalid ... multiple 'og:ur (5 posts)

  1. SadButMadLad
    Member
    Posted 2 years ago #

    When publishing a post I get

    Failed posting to your Facebook Timeline. Error: {"message":"Object at URL 'http://xxxxxx/' of type 'article' is invalid because it specifies multiple 'og:url' values: http://xxxxxxx/, http://xxxxxxx/.","type":"Exception"}

    Debug information from the plugin is

    {"appid":"9999999999","version":"1.0","domain":"xxxxxx","social_publisher":{"enabled":"true","publish_to_authors_facebook_timeline":"true","publish_to_fan_page":[],"mentions_position":"bottom"},"recommendations_bar":{"trigger":"50","read_time":"20","action":"like","side":"right"},"subscribe":{"layout":"standard","width":"250","colorscheme":"light","font":"arial","position":"both"},"comments":{"num_posts":"20","width":"470","colorscheme":"light"},"send":{"colorscheme":"light","font":"arial","position":"both"},"wp_ver":"3.4"}

    What settings do I need to check?

    http://wordpress.org/extend/plugins/facebook/

  2. Matt Kelly (Facebook)
    Member
    Plugin Contributor

    Posted 2 years ago #

    There have been a couple of threads about this-- please search before opening a new thread.

    Disable your other FB plugins. That will fix the issue. Thanks

  3. SadButMadLad
    Member
    Posted 2 years ago #

    Thanks for the quick reply. I haven't checked yet but it seems that it's because I have Yoast SEO. I'll have to decide between the two. Sorry about not searching, the link to search the forums was not that obvious, it being just a little link and the only search box obviously visible only searches plugins. Not your problem, but a problem with wordpress.org

  4. Matt Kelly (Facebook)
    Member
    Plugin Contributor

    Posted 2 years ago #

    No problem! I'll take a look at the Yoast plugin and see if we can fix it.

  5. thatruth2006
    Member
    Posted 2 years ago #

    @sadbutmadlad I don't think its a conflict with Yoast, I'm using it too and though I have major issues as well I don't have that problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic