WordPress.org

Ready to get started?Download WordPress

Forums

Facebook
[resolved] Incompatible with Disqus? (7 posts)

  1. kaylward
    Member
    Posted 2 years ago #

    Went through the setup and enabled only the social publisher. Now when I publuish a post I get this error.

    Warning: Invalid argument supplied for foreach() in /home/xxx/public_html/wp-content/plugins/facebook/fb-social-publisher.php on line 255

    Warning: Invalid argument supplied for foreach() in /home/xxx/public_html/wp-content/plugins/facebook/fb-social-publisher.php on line 297

    Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/public_html/wp-content/plugins/facebook/fb-social-publisher.php:255) in /home/xxx/public_html/wp-includes/pluggable.php on line 866

    The site uses Disqus and a Facebook App for Disqus commenting via Facebook login. I did not use that app for the plugin I used a new app.

    It seems that Disqus if setting the Disqus thread ID during the publish and then Facebbok is doing it's thing but the two conflict. The post is published, but Disqus is not setting the thread ID so no comments can be added to that post. Previous posts done prior to the Facebook plugin still can take Disqus comments.

    Anyone else having this issue

    http://wordpress.org/extend/plugins/facebook/

  2. consultorseo
    Member
    Posted 2 years ago #

    I have exactly the same problem.

  3. Samuel Wood (Otto)
    Tech Ninja
    Plugin Contributor

    Posted 2 years ago #

    Disqus, and any other plugin that uses Facebook code, will be incompatible with this plugin.

  4. kaylward
    Member
    Posted 2 years ago #

    Perhaps the install instructions should be updated to point out that you must disable any other plugin that uses Facebook code. Already we know that Disqus and Jetpack (if configured to use Facebook) are incompatible, but there are a lot more potentially incompatible plugins out there. Warning people up front that they need to examine their current plugins first would be helpful.

  5. sloppyperfectionist
    Member
    Posted 2 years ago #

    Interestingly enough I get exactly the same error, not having a single plugin other than facebook installed.

    I had, however, included the facebook Like-Button in all of my posts, making use of the code-snippet available from the facebook developer site. These have been removed as I had thought I wouldn't need them any more.

    I use a pretty simplistic, self-written theme, so I can't see what would interfere with the facebook-plugin.

    Any ideas? Any helpful hints will be greatly appreciated, so thanks in advance.

  6. Samuel Wood (Otto)
    Tech Ninja
    Plugin Contributor

    Posted 2 years ago #

    The specific errors given in the first post happen if you attempt to publish a new post without any mentions, and also have display_errors or WP_DEBUG turned on for your site.

    First, disable display_errors. The display_errors directive should *never* be enabled on a production site. These warnings would go away if you did that and it would work fine anyway.

    Second, the next version of the plugin will eliminate the warning messages. The messages don't cause any harm, they're just annoying, but nevertheless the next version will eliminate them.

  7. sloppyperfectionist
    Member
    Posted 2 years ago #

    Thank you. Another important lesson learned.

    (And sorry for double-posting my problem, I probably shouldn't have posted in a thread marked as solved)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic