WordPress.org

Ready to get started?Download WordPress

Forums

Facebook
Failed posting to Timeline because the access token expired (58 posts)

  1. cgcullen
    Member
    Posted 1 year ago #

    Failed posting to xxx Timeline because the access token expired. To reactivate publishing, visit the Facebook settings page and re-enable the "Publish to fan page" setting. Full error: {"message":"Error validating access token: Session has expired at unix time 1340290800. The current unix time is 1340377379.","type":"OAuthException"}

    I got the same error yesterday and re-enabled the "Publish to fan page" setting. Apparently didn't work. :(

    http://wordpress.org/extend/plugins/facebook/

  2. hypescience
    Member
    Posted 1 year ago #

    Similar error here:

    Failed posting to HypeScience's Timeline because the access token expired. To reactivate publishing, visit the Facebook settings page and re-enable the "Publish to fan page" setting. Full error: {"message":"Error validating access token: The session has been invalidated because the user has changed the password.","type":"OAuthException"}

    It does not work reactivating the option.

  3. hypescience
    Member
    Posted 1 year ago #

    It is working now. I deactivted and reactivated the plugin.

  4. Morten Rand-Hendriksen
    Member
    Posted 1 year ago #

    This error keeps popping up. From what I can tell it's Facebook timing out or timing out the access token. If you go into the settings for the plugin you'll see that the post to page option gets reset pretty much once a day. The only way I've found around it so far is to check to make sure it's set before I post something. Very annoying.

  5. Matt Kelly (Facebook)
    Member
    Plugin Contributor

    Posted 1 year ago #

    We're investigating this, thanks for the reports!

  6. Rick406
    Member
    Posted 1 year ago #

    I installed this plug-in on a 'non-profit' website I manage about about 3 weeks ago and have had the same problem; i.e. Publish To Fan Page [disabled]. When I go back in and select the website everything works properly for a short period of time. How about an option to 'publish to FB' an item already placed on the website? At least we wouldn't need to delete the item and then re-insert it. Thanks.

  7. hypescience
    Member
    Posted 1 year ago #

    Great, Matt! Please, let us know when you have a new version for us to test. I can give you feedback about it.

    I really do not like the way rss apps on Facebook publish our posts.

  8. drachenzauberei
    Member
    Posted 1 year ago #

    Interested in this as well!

  9. martong
    Member
    Posted 1 year ago #

    Yes, seeing this problem also, please fix.

  10. Jscuriosity
    Member
    Posted 1 year ago #

    this error message appears at any time I post. not once it showed my posts on my facebook page, i don't really know why to use this pluginn ... i used dlvr.it and ifttt so far and both worked well, but thought it would me more simple to use the facebook plugin. i am very disappointed :-( disabled the social share now.

  11. voodoomg
    Member
    Posted 1 year ago #

    any updates on this? this feature is really the main reason for using this plug-in.

    Can anyone suggest an alternative?...been a week and still no progress.

  12. martong
    Member
    Posted 1 year ago #

    Yes, I gave up on it because this feature was required. Switched to Plugin "Simple Facebook Connect". The setup is almost the same, easy to switch to. It also works with Timed Posts, this plugin does not. THis problem was posted in another post.

  13. Matt Kelly (Facebook)
    Member
    Plugin Contributor

    Posted 1 year ago #

    @cgcullen We believe we've fixed this in the latest dev version.

    You can give it a whirl at https://github.com/facebook/wordpress/zipball/master. If you could give that a try and let us know if it fixes your problem, that would be awesome.

    @martong The core author of SFC also work on this plugin. Also, this plugin works with timed posts. If you're seeing a bug, please open a new thread. Thanks!

  14. martong
    Member
    Posted 1 year ago #

    Thanks, Trying the new version now. Does this change the version number to something other than 1.02 in the plugin view after it is installed?

  15. martong
    Member
    Posted 1 year ago #

    I installed the patch above and it seems to have corrected the access token expired issue, however timed posts do not work. Will open a new post for that issue.

    Also the version number of the plugin does not change when you copy in the patch above.

  16. martong
    Member
    Posted 1 year ago #

    Well maybe not, I got this error on one of my other WP servers....

    failed posting to Books By Caroline Miller's Timeline because the access token expired. To reactivate publishing, visit the Facebook settings page and re-enable the "Publish to fan page" setting. Full error: {"message":"Error validating access token: Session has expired at unix time 1343786400. The current unix time is 1343830442.","type":"OAuthException"}

    Will check in to it.

  17. ialima7
    Member
    Posted 1 year ago #

    Same error... Why session is expiring?

    Additionally, the item 'Publish to fan page' is being changed to 'Disabled'. Someone also noted that?

  18. Matthew Hui
    Member
    Plugin Contributor

    Posted 1 year ago #

    Are you guys logging in/out of your facebook accounts before this error occurs?

  19. calleynye
    Member
    Posted 1 year ago #

    I'm not logging out, and I'm having the same problem.

  20. black lion
    Member
    Posted 1 year ago #

    After getting the latest update I get still the same error. Checking the fb-login.php I see the line:
    if ( false === ( $test = get_transient( 'fb_extended_access_token_' . $facebook->getUser() ) ) ) {
    $facebook->setExtendedAccessToken();

    //the extended token should be good for a couple of months, but lets refresh it every couple of weeks just in case
    set_transient( 'fb_extended_access_token_' . $facebook->getUser(), 'extended', 60*60*24*7 );

    I changed the 60*60*24*7 to 60*30*24*7.

    The great error is gone now, but the error: Failed posting to your Facebook Timeline. Error: {"message":"Could not retrieve data from URL.","type":"Exception"}
    is still there. But to the fangage and the timeline it send the message.

  21. ialima7
    Member
    Posted 1 year ago #

    Anyone out there using WPMU? I am suspicious that... This is happening only in sub-sites with different applications of the main site. Confirm?

    It was my case. Now I use the same Facebook application for the main site and the sub-site. And everything is going well. Is this the problem?

    @zazinteractive, I did not log out too.

  22. fedelosa
    Member
    Posted 1 year ago #

    Matt, I install 1.03, some of the problems are solved, including the <p> tag... but now I have this, see in the image, is easy to explain

    http://i.imgur.com/BFlfd.png

  23. black lion
    Member
    Posted 1 year ago #

    Till now I still going on this Facebook sharer, after I delete my apps on facebook itself and turn it back on by facebook-plugin it is going great. But there are still errors like this one"

    ERROR: Failed posting to your Facebook Timeline. Error: {"message":"Could not retrieve data from URL.","type":"Exception"}

    Checking my wall (i always on facebook) there is nothing to see. Going to my page te post is there. Going back to FB I see the post on my wall but NOT on the time line.
    So the last thing is somthing from facebook. They still keep on changing.

    But how to get rid of the ERROR above????

    Ik see that version 1.0.3 is there. Matt where to find this one???

  24. fedelosa
    Member
    Posted 1 year ago #

  25. black lion
    Member
    Posted 1 year ago #

    Hi Federico; I was trying that one to. Same problem. Take it out and went back. Now I got 1.00, 1.0.1 1.02, 1.0.3 All the same.I going to change the time limit. But next problem is coming up.
    He post to my wall (not timeline) and he post some times to my page. But on the page there nothig to see

    this plugin is hopeless.

  26. plumwd
    Member
    Posted 1 year ago #

    Hi there, just adding a "me too" to the list of people with the same issue. Hoping there's a fix soon, because this plugin has a lot of potential.

  27. black lion
    Member
    Posted 1 year ago #

    Guy's I know that this plugin is one of the best. That it is NOT doing what it have to do has 2 things.
    1- Facebook is chanching every time there schripts. So the devolpers got alway's a hard time to run after the facebook Devolpers.

    2-The Devolpers of this plugin doing every thing to fix the problems, but need information from the facebook Devolpers. If they get it then they can do there job, but in the mean time facebook also is chancing some thing else.

    SO whe have to have pation for the next update.

  28. black lion
    Member
    Posted 1 year ago #

    Till now (nok nok) its going ok. Except this error:

    Failed posting to your Facebook Timeline. Error: {"message":"Could not retrieve data from URL.","type":"Exception"}

    I stay inlogged on FB, but still the samen.
    Posting to my FB page is going great (Till now) I use the 1.0.3 version.

    So somewhere is it a bug or a FB problem.

  29. black lion
    Member
    Posted 1 year ago #

    Oke: Today. Yesterday before I stopped working I deactivated "the facebook plugin 1.0.3".
    This morning started to work. Reactivated "Facebook" and sending my first news item. It came in the timeline of the newspaper timeline and on my startpage (GOOD) Not on my fan-timeline (BAD) No worry.
    After 25 news items it was still going (GOOD). I am happy. After the 50th item still good.

    But still every item
    {Failed posting to your Facebook Timeline. Error: {"message":"Could not retrieve data from URL.","type":"Exception"} (BAD)

    No more <p> and </p> (GOOD)

    Missing only the tumbernail or Item-image in the items (BAD)

    So far so good After the 75th Item he whas still going good.

    Matt I am waiting for your comment on this.

  30. LGRD
    Member
    Posted 1 year ago #

    Getting the same problem.

    Using WPML if that has any effect.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic