WordPress.org

Ready to get started?Download WordPress

Forums

Facebook Comments for WordPress
Like button being reset (11 posts)

  1. jdku
    Member
    Posted 3 years ago #

    Hi,

    Have tried this in Chrome, IE and FF but all with the same results. Whenever you 'Like' a post it will either instantly change back to 'be the first of your friends to like this' or it will say you've liked it, but nothing appears on your wall in FB and if you refresh the WordPress page the Like button goes back to 'be the first of your friends to like this'.

    Have tried V1, V2 and New comment system, nothing changes.

    http://wordpress.org/extend/plugins/facebook-comments-for-wordpress/

  2. Paul OFlaherty
    Member
    Posted 3 years ago #

    I'm not sure this is a problem with the plugin. I'm seeing the same behavior on many sites today including some of my own.

  3. claycook
    Member
    Posted 3 years ago #

    i am having the same issue on my blog http://www.claycook.net

    however i only just installed the plugin 24 hrs ago

    is it something to do with the new version of wordpress?

  4. jdku
    Member
    Posted 3 years ago #

    think i've spotted the problem. for some reason the XID hasn't been generated on this install. that's the only difference i can find between this install and another i have that works absolutely fine!

  5. jdku
    Member
    Posted 3 years ago #

    OK, scrap that totally didn't work. Deleted it, reinstalled and got an XID number but still does exactly the same thing...stumped!

    Can server settings conflict? As the only difference now between the two installs are the servers they are on?

  6. Paul OFlaherty
    Member
    Posted 3 years ago #

    I'm still having the problem on some of my sites even with the plugin deactivated so I don't think the plugin is responsible for the like button being reset. I've also noticed a number of larger sites such as Ars Technica having the same issue with the Like button.

  7. claycook
    Member
    Posted 3 years ago #

    a friend found the fix for me.
    you need to clean your URL you have the button on with Facebook URL Linter...
    http://developers.facebook.com/tools/lint/

    it kind of has the effect of indexing the url with facebook and the like button for that URL magically works again.

    i did it for this page here as an example...
    http://www.claycook.net/ebook/

  8. claycook
    Member
    Posted 3 years ago #

    by the way - i am no longer using the plugin
    instead i am using https://developers.facebook.com/docs/reference/plugins/like/

    however i believe the URL Linter will fix the plugin issue also

  9. Jack Yan
    Member
    Posted 2 years ago #

    It’s definitely not restricted to WordPress and appears to be a bug on the Facebook end. I’ve encountered it not only on my WordPress blogs, but on a Mediawiki site I have, as well as one that I’ve hard-coded.

    Clay’s link works (thank you, Clay) but it doesn’t help our readers, who might not want to go to the trouble. :(

  10. Paul OFlaherty
    Member
    Posted 2 years ago #

    URL Linter is only a temporary per post fix. You'll have to lint the URL of every post you publish, which is what we are doing right now and it's a royal pain with 30+ posts a day.

    It's definitely 100% a Facebook problem.

  11. halluzineyt
    Member
    Posted 2 years ago #

    I hope this can be solved coz i have around 1k posts.. ouch,.,.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic