WordPress.org

Ready to get started?Download WordPress

Forums

Facebook AWD All in one
[resolved] Ok, another. Won't publish to timeline, says "You must p (3 posts)

  1. Rob Roy
    Member
    Posted 2 years ago #

    Publish Actions
    You must publish at least one action to your Timeline using this action type. Review the documentation.

    When I submit my action on Facebook Developers, it gives that error. I followed the instructions on your Wiki for getting the plugin to post to Timeline. The code is being called in the single.php

    <span class=" AWD_facebook_custom_action" data-type-event="AWD_facebook_tracker" data-action="read" data-object="article" data-url="http://chicagophoenix.com/2012/03/29/garofalo-talks-lgbt-youth-health-advocacy-at-uic/" data-responsetext="" data-callbackjs=""></span>

    But it isn't posting to my Timeline when I read the story. I'm assuming its because the action hasn't been submitted to Facebook for review, but I don't understand what the issue is.

    Here is the Facebook linter, there are a couple of Open Graph errors: http://developers.facebook.com/tools/debug/og/object?q=http%3A%2F%2Fchicagophoenix.com%2F2012%2F03%2F29%2Fgarofalo-talks-lgbt-youth-health-advocacy-at-uic%2F

    http://wordpress.org/extend/plugins/facebook-awd/

  2. AHWEBDEV
    Member
    Plugin Author

    Posted 2 years ago #

    For the errors on openGraph
    fb:page_id, is not comatible with this type of object, please set this field as empty.
    For the image i will update with a new format for thumbnail.
    But you should install another plugin to regenerate all thumb for backward compatibility.

    For the action:

    Publish Actions
    You must publish at least one action to your Timeline using this action type. Review the documentation.

    The Docuementation for action contains all warning about submissions.

    {"message":"Error: Unknown path components: \/chicagophoenix:read","success":false,"htmlResponse":"","callbackJs":"","debug":true}

    This is the error returned form firebug, when the action is posting from your site.
    That mean you created an action automatically via the "start openGrpah form" on facebook.

    Go on facebook settings, remove the action facebook created for you.
    And add a new one by hand.

    Do not let facebook configure it for you.

    Then if the problem is still here submit a new ticket on the project tracker to get more help.

  3. Rob Roy
    Member
    Posted 2 years ago #

    Ok - deleted the facebook generated action and creating one of my own worked perfectly!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic