WordPress.org

Ready to get started?Download WordPress

Forums

Extra User Fields
does not finish saving after typing in a new field definition (6 posts)

  1. edbeckmann
    Member
    Posted 2 years ago #

    Hi Frank

    I downloaded the current version 1.0.1 today and installed. The system is running on localhost on linux mint, mysql Sadly there are two errors:

    1. after I pressed activate the settings prompt appeared in the plugin list. Press that and I get an error "The requested URL /wp-admin/options-general.php was not found on this server."
      The apache log file shows confusion between file location and URL - [Wed Mar 14 12:45:02 2012] [error] [client 127.0.0.1] File does not exist: /var/www/wp-admin, referer: http://localhost/wordpress/wp-admin/plugins.php
    2. using the settings >> Extra user fields I see the proper screen but saving a new definition keeps the 'egg-timer' going and does not seem to finish saving. I deleted my entry and tried 2 of your examples without success. If I click on user profile and ignore the egg-timer the user profile has a heading at the bottom of the form "Extra user fields settings" but nothing after that

    Thanks for trying, it looks like it could be good!

    Ed Beckmann

    http://wordpress.org/extend/plugins/extra-user-fields/

  2. edbeckmann
    Member
    Posted 2 years ago #

    Update

    There seem to be two problems, one solved and one not.

    /extra-user-fields/extra-user-fields.php has an error in line 27, where the location of the wordpress files is hard coded and not a variable. So it will work if your site is at http://yourwordpress but not if it is at http://yourdomain/wordpress/.

    Temporary fix is to amend according to your setup, but the ideal would be to read it from the general settings file (sorry - that is beyond my experience to code).

    When this is done, it seems that Google Chrome (17.0.963.79) will still have the same response to #2 above. Firefox works perfectly and does not display error #1 above either.

    Ed

  3. adrianbridgett
    Member
    Posted 2 years ago #

    patch for problem #1

    `--- /tmp/extra-user-fields.php 2012-03-21 09:14:54.000000000 +0000
    +++ ./extra-user-fields.php 2012-03-21 09:44:13.000000000 +0000
    @@ -24,7 +24,7 @@
    function extrauserfields_action_links($links, $file) {
    if ( defined('EXTRAUSERFIELDS2') ) return $links;
    if ( $file != 'extra-user-fields/extra-user-fields.php' ) return $links;
    - $settings_link = '' . esc_html( __( 'Settings') ) . '';
    + $settings_link = '' . esc_html( __( 'Settings') ) . '';
    array_unshift( $links, $settings_link );
    return $links;
    }

  4. adrianbridgett
    Member
    Posted 2 years ago #

    let's try that again... (can't see a "preview" option)

    --- /tmp/extra-user-fields.php 2012-03-21 09:14:54.000000000 +0000
    +++ ./extra-user-fields.php 2012-03-21 09:44:13.000000000 +0000
    @@ -24,7 +24,7 @@
    function extrauserfields_action_links($links, $file) {
    if ( defined('EXTRAUSERFIELDS2') ) return $links;
    if ( $file != 'extra-user-fields/extra-user-fields.php' ) return $links;
    - $settings_link = '' . esc_html( __( 'Settings') ) . '';
    + $settings_link = '' . esc_html( __( 'Settings') ) . '';
    array_unshift( $links, $settings_link );
    return $links;
    }

  5. adrianbridgett
    Member
    Posted 2 years ago #

    sigh. okay

    basically insert at the start of settings_link URL:
    get_option('siteurl')

  6. marcusstenbeck
    Member
    Posted 2 years ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic