WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Exec-PHP] Bug: This plug-in dsiabled my Editor role comment moderation functionality (8 posts)

  1. ldexterldesign
    Member
    Posted 4 years ago #

    More details here: http://wordpress.org/support/topic/335007?replies=1#post-1291866

    Hope to see this fixed in the next version.

    Thanks,

    http://wordpress.org/extend/plugins/exec-php/

  2. McShelby
    Member
    Posted 4 years ago #

    Works for me in WordPress 2.9.

  3. ninjaWR
    Member
    Posted 4 years ago #

    Tested in WordPress 2.8.0, 2.9.1, and 3.0-alpha. While the plugin was activated, my editor could see all comments, but couldn't moderate any.

  4. ninjaWR
    Member
    Posted 4 years ago #

    More to add...

    After installing the Capability Manager plugin, I assigned editors the Edit others PHP capability, and they could moderate comments again.

    I also assigned them Exec php, so the Exec-PHP plugin wouldn't complain about a "security hole", since I trust those in the editor role.

  5. avcascade
    Member
    Posted 4 years ago #

    Exec-PHP 4.9 also prvevents editors from editing others' posts when it is activated in WordPress 2.9.1. Experiencing this problem now. Deactivating the plugin restores editors' ability to globally edit posts. I would definitely classify this as a bug... a plugin should not disable the normal functionality of WordPress. Hope this gets fixed.

  6. matius
    Member
    Posted 4 years ago #

    Agree with avcascade, that's no good.

  7. csw
    Member
    Posted 4 years ago #

    Hi,

    I'm having the same problem. But it happen for the administrator role, and no Exec-PHP plugin has been install.

    Below is the Error msg:-
    "Error 403
    We're sorry, but we could not fultill your request for /blogname/wp-admin/edit-comments.php?p=1433#comments on this server.
    You do not have permission to access this server. etc..."

    Please help.

  8. dfisek
    Member
    Posted 3 years ago #

    I'm having the same problem as avcascade. It's annoying there's no fix or workaround for this problem though many months have passed.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags