WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Exclude Pages] Help - Duplicate "exclude_page" custom fields (8 posts)

  1. steve49589
    Member
    Posted 5 years ago #

    I may have made a mistake by uninstalling the plug in while it was still active?

    I'm getting duplicate Custom Field entries - MANY of them - on pages. The custom field added is exclude_pages and the value is 0. Every time I save a page, I get a new custom field entry called exclude_pages.

    At some point I must have removed the plug in since I was not using it, but the above started happening at some point.

    I added the plug in back to the system in hopes it would clear up the issue. Still the same issue.

    Can someone help?

  2. MichaelH
    Member
    Posted 5 years ago #

    Wonder if you have duplicates in wp_postmeta? If so backup your database and consider using this in phpMyAdmin
    DELETE FROM wp_postmeta WHERE meta_key = 'exclude_pages' AND meta_value = '0';

  3. steve49589
    Member
    Posted 5 years ago #

    Thank you for the reply, but that did not solve the issue.

    Every time I save a page, I get a new custom field added with the name exclude_page and a Value of 0.

    Stumped.

    Anyone else?

  4. steve49589
    Member
    Posted 5 years ago #

    Bump. This is really bugging me. And deleting all of these references as I build out the site is getting a bit annoying.

  5. mackaaij
    Member
    Posted 4 years ago #

    I came here for the same problem and since there is no movement on this topic I figured two options:
    1. Don't use a plugin and build your own "page" menu as a widget and manually add the pages you do wish to show.
    2. Try this plugin: http://wordpress.org/extend/plugins/exclude-pages/

  6. mackaaij
    Member
    Posted 4 years ago #

    I decided in favor of my first option. After removing the plugin I deleted all the custom fields entries from the database (to clean up) using this SQL statement:

    delete FROM <dbname>_postmeta WHERE meta_key = 'exclude_page'

    (please note the meta_key is indeed 'exclude_page' and not 'exclude_pages' as mentioned above)

  7. steve49589
    Member
    Posted 4 years ago #

    There is a plug in conflict. I thought I had updated this thread, but I did not. Hang on, let me check my e-mail.

  8. steve49589
    Member
    Posted 4 years ago #

    The conflict is between a plug in called Hide Pages (http://www.instinct.co.nz/hide-pages-plugin/) and a plug in called Exclude Pages (http://wordpress.org/extend/plugins/exclude-pages/).

    They both use the same exclude_page reference in the code. Ensure you are only using one of them.

Topic Closed

This topic has been closed to new replies.

About this Topic