WordPress.org

Ready to get started?Download WordPress

Forums

Exclude Pages
Exclude is not working well on large websites (8 posts)

  1. erjon
    Member
    Posted 1 year ago #

    Hi i have a website thats's over 1000 pages and running into some issues with the plugin. The plugin sometimes shows the links that I have set to Exclude from the sidebar and sometimes it works fine, it's so odd. It excludes the pages that I want to exclude for a while and then it includes them by itself. This plugin is very important for my site and I would like to resolve this issue. I dont want to switch to another plugin, because I have set over 100 or so pages to to exclude from the sidebar.

    If you could help me solve this issue I would appreciate it.

    Thanks

    http://wordpress.org/extend/plugins/exclude-pages/

  2. TDerouinDesign
    Member
    Posted 1 year ago #

    I am also having this problem all of a sudden. I do not have a site as extensive as yours that I am working on but as you stated, this is a very important plugin. I appreciate any feedback, thank you.

  3. TDerouinDesign
    Member
    Posted 1 year ago #

    Also, is there anyone out there with a small website that is having this issue? Or is it truly a problem with websites with more than a handful of pages?

  4. Len
    Member
    Posted 1 year ago #

    I am having the same problem. It has now occurred twice. Is there a fix? Does anyone know of another plug in that accomplishes this? I am no power user and don't want to mess with lines of code if I can avoid it. I have hundreds of pages and cannot deal with resetting them every few weeks. It seems to occur after I add a new excluded page.

  5. Len
    Member
    Posted 1 year ago #

    I figured out a simple hack that mostly fixes this problem. I put all of my hidden pages behind a parent page I call Hide Page, then I hid the Hide Page from navigation. Not perfect, but if the plug in fails again I only have to re-hide one page.

  6. 2WW
    Member
    Posted 1 year ago #

    Have exactly the same problem on a smaller website. The hack of 'hide page' works, but this is not great as part of the SEO. Hope the problem will be fixed soon.

  7. 2WW
    Member
    Posted 1 year ago #

    Somehow it has to do with the theme. When I change it to an other theme, all works fine. So I in- and excluded pages and changed back to the old theme. The pages have changed successfully, but the problem persists again. So the plugin stills seems to be working.

  8. TDerouinDesign
    Member
    Posted 1 year ago #

    You may have been able to resolve it for the time being, but in my experience the problem will come up again if not today, or tomorrow, soon. Let us know here on the forum how you make out but I though I had resolved the issues multiple times and finally had to hardcode the navigation as an alternative and won't go back to using the plugin until I know something has been resolved and/or we hear from the plugin developer.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic