WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] Upgrade-resistent translation (10 posts)

  1. Erling
    Member
    Posted 2 years ago #

    I have no problem with the translation and getting it to work.
    BUT as far as I can see here in support forum this question is not answered:
    Is there a place to put the translation files so it's not affected at every upgrade of the plugin?
    I always have to use ftp and then reload my Danish translation files.

    http://wordpress.org/extend/plugins/events-manager/

  2. agelonwl
    Member
    Posted 2 years ago #

    hi,

    Once you’ve translated the file, why not send it over? By doing this you’re helping the community and also making sure your site remains translated when automatically updating the plugin. If you’ve never contacted us before, please use the contact form and let us know that you have a translation for us, we will inform you where to send the translation files.

    - http://wp-events-plugin.com/documentation/translating/

  3. Boettcher
    Member
    Posted 2 years ago #

    With pleasure. Although I have to say that I at a few points translated for my purpose (a sports club) - eg. "categories" became "groups" (differnt teams) - but this should be no bigger problem.

  4. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    at the moment there isn't for these cases, eventually, I would like it to check e.g. wp-content/lanaguages first

  5. Erling
    Member
    Posted 2 years ago #

    Except a final workover on the details I'm ready with a Danish translation.
    How and where to send it?
    But meanwhile the translation only work on the one site and not at the other of the two where I'm developing a new site - with ecactly the same .po and .mo files.
    I installed plugin "Codestyling localization" and it says the following:
    -------
    Project-Id-Version: Events Manager v5.1.8.5 | Fil: includes/langs/dbem-da_DK.po
    Error: The actual loaded translation content does not match the textdomain: dbem
    Expect, that any text you translate will not occure as long as the textdomain is mismatching!
    This is a coding issue at the source files you try to translate, please contact the original Author and explain this mismatch.

    Warning: The actual loaded translation content contains mixed textdomains and is not pure translateable within one textdomain.
    It seems, that there is code contained extracted out of other plugins, themes or widgets and used by copy & paste inside some source files.
    The affected unknown textdomains are:
    ---

    Do you have an idea what I can do?

  6. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    where do you see this error? works fine for me (I use it to generate pot files), so I'd check your plugins/theme etc. to see if there's a conflict

  7. Erling
    Member
    Posted 2 years ago #

    The message appears in the plugin "Codestyling localization" when I open the Events Manager to translate.
    The plugin work fine for every other plugin on the site.
    The strange thing is that also if I use Poedit and ftp to translate in the db-em language file - many of the translations don't show up.
    Look for example on the left sidebar on the present site http://ishojvolley.dk and on the site under construction on http://ishojvolley.dk/2
    It's not possible to translate the Weekdays to Danish on the coming site.

    I have de-activated everything, and it didn't help.
    Are you sure there isn't something wrong with the language-files following the latest EM-update?
    Before I had not such a problem and it's only concerning EM.

    Best regards
    Erling

  8. agelonwl
    Member
    Posted 2 years ago #

    Hi,

    I installed the plugin "Codestyling Localization" and try the above translations but all seems to work fine.
    e.g.
    Project-Id-Version: Events Manager v5.1.8.5 | File: includes/langs/dbem-da_DK.po

    Im using default twentyeleven theme on my test site.

  9. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    May be worth deleting and installing the plugin again (not uninstall, delete, which doesn't wipe any event data/settings)

  10. Erling
    Member
    Posted 2 years ago #

    Forgot to say: Thank you.
    It worked with your last suggestion.
    But I'm now a bit suspicious towards this Codestyling Localization plugin - will do it the usual way, with PoEdit and FTP.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.