WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
Upgrade from 4 to 5 doesn't seem to work (13 posts)

  1. pieyum
    Member
    Posted 2 years ago #

    Hello, I had EM 4 installed and I followed the simple instructions to upgrade to 5.0.4. Everything seemed to have gone smoothly but now I've had the "Events Manager upgrade still in progress. Please be patient, this message should disappear once the upgrade is complete." message displaying and none of my events seem to have transferred properly. I've given it a good hour and still nothing. What's more is my EM Widgets that were there previously seem to be showing my latest post rather than an event.

    http://sunriseartists.com

    I really need some help with this ASAP. Even if it means to recreate the events from scratch (There were only 10 or so anyway so it is manageable). I just have to get rid of that message somehow to begin with.

    Thank you in advance!
    Pi

    http://wordpress.org/extend/plugins/events-manager/

  2. Daniel Payne
    Member
    Posted 2 years ago #

    I'm stuck with the same Update issue, "Events Manager upgrade still in progress".

    Love the plugin, hate that it failed to Update.

  3. jolaedana
    Member
    Posted 2 years ago #

    I am having this issue with a client's site, and I am hoping to get feedback soon. Any help would be great!

  4. Daniel Payne
    Member
    Posted 2 years ago #

    I had to rename the plugin folder "events-manager" to "events-manager-broke" then upload an older version 5.0.1, then upgrade 5.0.1 to the latest release.

    My events are working however I still have the red letter warning, "Events Manager upgrade still in progress".

    Hey, it's free software so I guess I can live with that false nag message.

  5. jolaedana
    Member
    Posted 2 years ago #

    Thanks, @Daniel - Since it's a client's site, I'm avoiding your solution since the warning still sticks and they may panic- but it's good to know you can get the events to come through.

    For now, I've just downgraded the client to the most up to date 4. version- will definitely be keeping eyes open for a fix on this one. If I find anything, I'll post here.

  6. macedarc
    Member
    Posted 2 years ago #

    Hello,
    i also have the same problem as I do to retrieve events?

  7. jolaedana
    Member
    Posted 2 years ago #

    @macedarc, downgrading to vs. 4.305 should work: http://wordpress.org/extend/plugins/events-manager/download/

    Alternately, you can follow Daniel's approach, and download 5.0.1 at that same page, downgrade to that, and then upgrade using the normal WordPress upgrade method.

    To downgrade, you simply deactivate the plugin rename the folder to something else so you don't lose anything (it will be in your wp-content/plugins/events-manager directory), and upload the older version of the plugin to your wordpress wp-content/plugins directory.

  8. sunkast
    Member
    Posted 2 years ago #

    I had this same issue. EM is a really one of the best events plugins out there. And no offense to Marcus, and those that have contributed to the development. But the update process between major versions hasn't been very good. I've been using EM since version 2. And with each major release, I've had issues with events going missing.

    From my experience, it doesn't appear that you can upgrade to a major release without being on the very latest previous version first. Meaning that the only upgrade path from v4 to 5 is if you are already on 4.305. I found this to be the same going from v3 to 4.

    So in this case, I had to manually update first to v4.305 since I was not running the the newest version of 4. Then manually install the first 5.0 beta. This worked for me, and I was able to automatically update to 5.04 after that without losing my events.

    Thanks to jolaedana for pointing out using 4.305 first.

    It was rather frustrating figuring out this process, and having it happen yet again during an update from an old version, to the newest. I really wish the developers would work to improve the upgrade process between major releases.

  9. interpotential
    Member
    Posted 2 years ago #

    I managed to get rid of this message by looking at the code, and fixing an (apparetly) little bug.

    On line 876 of em-install.php, there is a call to a function named is_set, which looks like it should have been isset. By changing this, and forcing the upgrade by adding true || to the if struct on line 17 it managed to complete the update, and get rid of the message.

  10. agelonwl
    Member
    Posted 2 years ago #

    yes, that will be fix on the next update.

  11. pieyum
    Member
    Posted 2 years ago #

    Thank you all. I did the downgrade to 5.0r1 and upgraded to the latest. Worked like a charm!

  12. jolaedana
    Member
    Posted 2 years ago #

    @interpotential, you rock. Thanks! Upgrading the client's install soon.

  13. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    @sunkast, we put out the betas and RCs but errors only seem to crop up when we release :)

    hopefully it's the last major upgrade, no more changes to the core code, these are never fun due to all the instances and ways EM can be used in.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic