WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] short codes not working (5 posts)

  1. Wish Web Geek
    Member
    Posted 1 year ago #

    I am using the plugin Secondary HTML Content to add the shortcode into the sidebar of my pages. I tried it once and it worked. When I tried to change the shortcode the event list would never show up, only the original content showed up. I got the same result when I removed all the shortcode. So I renamed the Secondary HTML content name and created a new one. When I put my shortcode in nothing shows up still.

    I have tried pasting the shortcode into the main page and it still doesn't work. I know there are events that match. Here is my shortcode:

    [events_list limit="3" scope="future" order="DESC" category="10,46,55"]<p>#_EVENTLINK #_EVENTDATES</p>[/events_list]
    See all trips >

    Here's the page I'm trying to put it on: http://fs.flagstaffit.com/destinations/grand-canyon-hiking-backpacking/bright-angel-with-mule-support/

    Also, for future reference, do you have any problems with the plugin when a site is moved from a test site (like this one) to the live site? Do you have special procedures for doing this?

    Thanks.

    http://wordpress.org/extend/plugins/events-manager/

  2. agelonwl
    Member
    Posted 1 year ago #

    1.

    When I tried to change the shortcode the event list would never show up

    can I know what do you mean and what changes you did? the shortcode above should worked.

    2. None, it should worked;

  3. Wish Web Geek
    Member
    Posted 1 year ago #

    1. The original shortcode was this:

    [events_list limit="4" scope="future"]<p>#_EVENTLINK #_EVENTDATES</p>[/events_list]

    but when I changed it (as in my original post) the results from this original code showed up (even when I removed all code the original code results showed up.

    I tried to post the short code in the post area at the very bottom of the page, but as you can see nothing is showing up.

    the php I'm using in the template is this:

    <?php while ( have_posts() ) : the_post(); ?>
    	<div id="post-<?php the_ID(); ?>">
    		<div class="sidebar-entry">
    		    <?php the_secondary_content('upcomingtrips'); ?>
    		</div>
    	</div>
    <?php endwhile; ?>
    
    2. So I did try adding this code: [events_list limit="3" scope="future" order="DESC" category="50"]<p>#_EVENTLINK #_EVENTDATES</p>[/events_list]<a href="/events/">See all trips ></a>

    to this page: http://fs.flagstaffit.com/destinations/baja-kayaking/espiritu-santowhale-watching/

    and it's working perfectly. And I did edit it and reload and it worked. But for some reason the original page I tried is not working at all. Any ideas?

    Thank you.

    [Moderator Note: Please post code or markup snippets between backticks or use the code button. As it stands, your code may now have been permanently damaged/corrupted by the forum's parser.]

  4. Wish Web Geek
    Member
    Posted 1 year ago #

    Well, I just deleted the php code from the template and then uploaded. Then added back and uploaded. Now it works.

  5. agelonwl
    Member
    Posted 1 year ago #

    thanks for updating;

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic