WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] rewrite rules trigger "Compilation failed" warnings (7 posts)

  1. webaware
    Member
    Posted 1 year ago #

    FYI: PHP=5.3.14

    Events manager 5.1.8.5 is generating warnings as follows:

    Warning: preg_match() [/phpmanual/function.preg-match.html]: Compilation failed: nothing to repeat at offset 1 in /data/websites/angove/wp-includes/class-wp.php on line 201

    Warning: preg_match() [/phpmanual/function.preg-match.html]: Compilation failed: nothing to repeat at offset 1 in /data/websites/angove/wp-includes/class-wp.php on line 202

    This is due to an unescaped "?" in the following regexes, which PHP is trying to interpret as a shortcut for {0,1}:

    ?page_id=871/(\d{4}-\d{2}-\d{2})$
    ?page_id=871/rss$
    ?page_id=871/feed$
    ?page_id=871/event/(.+)$
    ?page_id=871/location/(.+)$
    ?page_id=871/category/(.+)$
    ?page_id=871/?$

    s/871/your events page/g

    In all cases, I reckon you should be escaping the "?" as "\?"

    cheers,
    Ross

    http://wordpress.org/extend/plugins/events-manager/

  2. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    I'm guessing this is when you're not using permalinks?

  3. webaware
    Member
    Posted 1 year ago #

    Ha... now that you mention it, it seems that this website hasn't been configured for events yet (no events page selected, for example). So, maybe this can be ignored? :)

    [NB: someone else set this one up, I was just seeing the warnings on my dev copy when working on some other aspects of the website]

  4. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    I've noted this down and will fix asap (probably after the 5.1.9 update)

  5. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    btw, in case I don't reproduce this, are you getting this on every page, or on specific instances?

  6. webaware
    Member
    Posted 1 year ago #

    G'day Marcus, sorry if I wasn't clear before, this was happening because Events Manager hadn't been configured. I went to the Permalink Slugs section of Events settings and saw that there were the usual slugs, hit Save All Changes, and it's fixed. It was simply a matter of someone installing the plugin but not configuring it.

    FYI: yes, it was all pages, because it was in the rewrite rules; but fixed now since above done.

  7. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    I guess I'll leave it at that for now then :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.