WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
Page 404 after submit (15 posts)

  1. veluwe
    Member
    Posted 2 years ago #

    Hi,

    Started today with Event Manager. Great plugin! After installation and setting changes, etc. I made my first event. Everything is working fine and is posted correctly.
    Link: http://veluwegranen.nl/blog/?event=thema-avond-zelf-voer-mengen

    However when trying to make a booking, no booking is made and page redirected to:
    http://veluwegranen.nl/blog/blog/?event=thema-avond-zelf-voer-mengen. (note: 2 times /blog)
    This generates a page 404-error not surprisingly. Also no booking is made, no email is send out. Can someone help me further with this.

    Edit: Permalinks are standard permalinks, no changes made.

    Thanks.

    Gerard

    http://wordpress.org/extend/plugins/events-manager/

  2. agelonwl
    Member
    Posted 2 years ago #

    First, if possible to try deactivating other plugins or reverting to default theme because conflicting plugin or theme can cause this.

  3. veluwe
    Member
    Posted 2 years ago #

    Thanks for fast answer.

    Deactivated all plugins (except EMP :-) ). All pages are on standard template. Same behavior so far.

  4. agelonwl
    Member
    Posted 2 years ago #

    what is EMP? and also what is your theme name TwentyEleven?

  5. veluwe
    Member
    Posted 2 years ago #

    Meant EM (event manager). Standard theme twenty eleven, correct.

  6. agelonwl
    Member
    Posted 2 years ago #

    can you try to resave permalinks? wordpress Settings > Permalinks > Click save changes

  7. veluwe
    Member
    Posted 2 years ago #

    Just did so, but no luck.

    I'm merely thinking that the 'submit' button isn't working correctly, while all other pages and links (like to locations and eventpage) work correctly.

  8. agelonwl
    Member
    Posted 2 years ago #

    Also, can I know the settings in your EM Settings > Pages > Permalink slugs and how about choosing a different wp permalinks then go back to the default one.

  9. veluwe
    Member
    Posted 2 years ago #

    EM permalinks:
    Event: Events
    Locations: events/locations
    Categories: events/categories

    choose different permalinks (saved) and reverted back (saved). No luck.

  10. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    did you try the 2011 theme? chances are it's your theme

  11. veluwe
    Member
    Posted 2 years ago #

    Just tried. You are right, it's something in my theme.

    Do you have any idea where to look?

  12. dobiejrn
    Member
    Posted 2 years ago #

    I'm having this issue as well, my blog is in a sub directory. The server[request_uri] in bookingform.php is pulling the sub directory with the variable. I added:
    $urlrev=substr($_SERVER['REQUEST_URI'],(strlen($_SERVER['REQUEST_URI'])-4)*-1);

    quick fix - the -4 represents the /wla as the subdirectory,

    and modified the form action:
    apply_filters('em_booking_form_action_url',home_url($urlrev));

    The action is now correct and the 404 error is gone but now it doesn't recognize the user registering. I'm guessing this is a different issue all together. Starting to look at this.

    Was using a modified blogolife theme.

    Jeff

  13. veluwe
    Member
    Posted 2 years ago #

    Thanks a lot Jeff. My blog is also in a subdirectory and has a modified theme. So, maybe that combination doesn't work well.

    So, step 1 solved, but the main problem persists: no booking made.

    Well, if I found something I'll let you know.

  14. pennisol
    Member
    Posted 2 years ago #

    patch works. Booking too, but no confirmation mails

  15. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    @pennisol, that'd be a different bug, check your mail settings (there's some other simimilar topics on email from today, not a bug but setup issues)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic