WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] ical per event not working (7 posts)

  1. MLeBlanc
    Member
    Posted 2 years ago #

    I'm trying to add an ical link per event with the following template code:

    <a href="#_EVENTICALURL">Add to Calendar</a>

    This adds /ical to the end of the event URL. When the link is clicked, the page is refreshed and nothing happens.

    However, when I hit mydomain.com/events.ics, everything works as expected. I really need individual dates to work with ical, has anyone else reported problems with it?

    http://wordpress.org/extend/plugins/events-manager/

  2. agelonwl
    Member
    Posted 2 years ago #

    seems to be working fine on me, can you try to temporarily deactivate other plugins or preview it using default theme? Also, do you have a sample link?

  3. MLeBlanc
    Member
    Posted 2 years ago #

    Hmm. Thanks for the reply. Tried disabling my plugins, though I don't think I have anything that would conflict:

    Contact Form 7
    Contact Form 7 Widget
    Sharedaddy
    Widget Logic Visual

    Also tried setting WP back to the default Twenty Eleven theme, no luck.

    Any other ideas?

    Maybe another ical plugin compatible with Event Manager?

  4. MLeBlanc
    Member
    Posted 2 years ago #

    UPDATE:

    Ok, so I created a fresh WP install and got the iCal thing working - here's what I found:

    The problem is in permalinks. On my site I'm using a custom permalink structure:
    /%category%/%postname%

    This is a requirement for SEO reasons.

    The only way I can get iCal to work is using the WordPress default permalink structure:
    ?p=#

    Can/will the plugin be modified to work using a rigid permalink structure?

    Thanks

  5. MLeBlanc
    Member
    Posted 2 years ago #

    UPDATE AGAIN:

    Using the Numeric permalink structure it appears to be working but also allows my page slugs to be named correctly.

    Thanks

  6. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    i get this too, will check it out and see what can be done

  7. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    in case you still get this, the dev version has an update which fixes this

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic