WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] Full calendar ajax (12 posts)

  1. Extrafino
    Member
    Posted 1 year ago #

    What could be the cause of the full calendar view ajax not working anymore?
    I am using the latest versions of wordpress, events-manager and google-cdn delivery of jquery and jquery-ui.
    I tried removing google-cdn, clearing the cache and reloading the page, but the calendar will not use ajax but switch to a new page using the ajax url.
    Does events-manager require specific versions?

    All classes in the calendar view are default, I changed no names...

    http://wordpress.org/extend/plugins/events-manager/

  2. agelonwl
    Member
    Posted 1 year ago #

    Hi,

    do you have a sample link and is that mean that you are using wp 3.4 and EM 5.1.8.2 ? also, can you try to clear cache and refresh your browser again?

    also, try disabling plugin and reverting to default theme.

  3. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    it should be working as normal. The demo site uses the latest versions of WP/EM/Pro

    Check your JS error console as I'm sure it's probably related to that.

  4. Extrafino
    Member
    Posted 1 year ago #

    I get no errors in the console.
    I am using WP 3.4 and now EM 5.1.8.3

    This is the page in question:
    http://www.feg-wetzlar.de/veranstaltungen/

  5. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    looks ok to me, have you tried deactivating your other plugins and/or reverting your theme temporarily to see if it's one of these?

  6. netforest
    Member
    Posted 1 year ago #

    I have a similar problem. I am using WP 3.4.2, EM 5.2.8, and WP FullCalendar 0.7

    Ajax is not working. I tried disabling all the plugins except for EM & Fullcalendar and activated the Twenty Eleven Theme. And still not working. When I switch the Post type to Pages instead of Events it works. Must be something to do with events.

    The only thing I can think of is I had installed other plugins, TEC by modern tribe and AJax Event Calendar, but have deactivated and deleted them. Could something be left over from the plug-ins that I deleted.

    I also installed a new copy of WP in another directory and the Genesis themes I am using with the two above plugins and it works!

    http://www.isca.dreamhosters.com/test/calendar/

    Go figure!

    Any help appreciated. Here is the url that doesn't work:

    http://www.isca.dreamhosters.com/wtr/events-by-monthview/

  7. agelonwl
    Member
    Posted 1 year ago #

    hi @netforest

    both links are working fine upon testing.

  8. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    it may be the calendar plugin causing issues. try deleting any posts in your wp_posts table that have post_type event maybe that helps?

    but as angelonwl said, the links work for me too. if it still doesn't for you, what browser are you using?

  9. netforest
    Member
    Posted 1 year ago #

    That's really strange. When you hover over the event for the link http://www.isca.dreamhosters.com/wtr/events-by-monthview/ the event pops up. I can link to the event by mouse click but hovering over does nothing, just the message 'loading...'

    I am using Chrome, Safari, and Firefox on OS X. All latest versions. Marcus, if I delete all the events with post_type='event' it will remove all the records for the calendar. How would that help? Any other ideas? What browser and OS were you using where it worked?

  10. netforest
    Member
    Posted 1 year ago #

    One more thing. What I was describing here is that the Tool Tips aren't working on the above URL. FullCalendar uses the jquery qtip plugin and for some unknown reason does not work on my site. Can't think of anything else to try.

    puzzled!?

  11. netforest
    Member
    Posted 1 year ago #

    Viola! I went into Settings/Admin Tools of Events Calendar and Reset Events Calendar to its original settings and that fixed it!

  12. netforest
    Member
    Posted 1 year ago #

    Not working again. I found out the cause. Whenever I go into the Events Calendar/Settings and save them (even without making any changes, the tool tips stop working. Once I reset to defaults it works.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic