WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
Events Layout not working for shortcodes (7 posts)

  1. snatrott
    Member
    Posted 2 years ago #

    I edited the default Events format for the Events page and that works fine on the Events page that uses [events_list].

    I also created a page to display future events using [events_list scope="future"]. This page displays the events using the original format and not my modified layout.

    Working: http://www.webiforum.com/en/events/
    Not working: http://www.webiforum.com/en/upcoming-webinars/

    http://wordpress.org/extend/plugins/events-manager/

  2. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    Your second link is 404, is that what you see? If so that's a different issue, i.e. page not even found.

  3. snatrott
    Member
    Posted 2 years ago #

    My first link is the 404 because I changed the permalink of it. Very sorry about that. The correct links are:

    Working: http://www.webiforum.com/en/webinars/
    Not working: http://www.webiforum.com/en/upcoming-webinars/

    Both of those links are working, and I will not be changing them.

  4. snatrott
    Member
    Posted 2 years ago #

    Any luck with this one? I can set the templates in a file if that would work. I just need to know which file to create and/or put the code in.

  5. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    what are you using to generate the layout for the first page? you say you use events_list, but are you not using a default events page?

  6. snatrott
    Member
    Posted 2 years ago #

    I am using Events->Settings->Formats/Layouts->Events format to control the listing for the http://www.webiforum.com/en/webinars/ page. It is using the default events page just renamed. The top of the Webinars page says: This page corresponds to Events Manager events page. Its content will be overriden by Events Manager, although if you include the word CONTENTS (exactly in capitals) and surround it with other text, only CONTENTS will be overwritten. If you want to change the way your events look, go to the settings page.

    The layout on that page is working just fine. The pages using the scope attribute are not reading the Formats/Layouts code. I am using [events_list scope="future"] and [events_list scope="past"] and they are both showing the original layout instead of the layout I did with significant changes.

  7. snatrott
    Member
    Posted 2 years ago #

    Any chance anyone has found the reason why the pages containing shortcode for listing events are not using the formatting I have set? I can put the code in one of the files if that would work better. I just have to know which file.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic