WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] Default Location always overrides any other locations (11 posts)

  1. balla4eva33
    Member
    Posted 1 year ago #

    Hello,

    We're getting a strange bug related to locations. When a Default Location is set, when we select a different location (or enter a new one) it appears to work, but upon saving the location, the page refreshes and the Default Location is back. There doesn't appear to be any way to save a location with a location other than the default one. When I set the Default Location to none, everything works as it should. Thoughts? Ideas? Help?

    Please and thanks!

    http://wordpress.org/extend/plugins/events-manager/

  2. balla4eva33
    Member
    Posted 1 year ago #

    It looks like it may not even be just a Default Location issue. If I have an event with a location saved, then I try to update the location to a different/new one, it falls back to the one it was without saving my changes.

  3. agelonwl
    Member
    Posted 1 year ago #

    can I know what type of wp installation is this? e.g. multisite, buddypress or default? also, have you tried:

    - deactivating other plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    can I know what EM version you are using or have you tried the latest dev version?

  4. balla4eva33
    Member
    Posted 1 year ago #

    This is a multisite WP. Is that a problem?

    The only other plugin we have activated on the site right now is podPress and I did try deactivating that temporarily to see if it conflicted.

    I changed the theme back to Twenty Eleven as you suggested, but the problem still persists then also.

    It looks like we are on EM version 4.305.

    Thanks!

  5. balla4eva33
    Member
    Posted 1 year ago #

    I tried upgrading to the latest version, but I lost all my events, so I downgraded back to 4.305 and restored my DB backup. Any ideas what's up with my locations issue?

  6. agelonwl
    Member
    Posted 1 year ago #

  7. balla4eva33
    Member
    Posted 1 year ago #

    I already found/read both those posts and alas still had no events after the upgrade from 4.305 to the latest 5.1.8. Perhaps it's an issue with multi-site installs?? I don't mind if we have to stick with the older version, I just want the locations functionality to work correctly. Any ideas on that?

  8. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    wouldn't be able to help you with issues on 4.x

    when you upgrade to 5, do you see events on your front-end or back-end or no-where?

    You need to check your PHP error logs to see if something went wrong during the install.

  9. balla4eva33
    Member
    Posted 1 year ago #

    Hey guys, I finally got around to upgrading to latest version and I'm getting the error again. I've followed both the links given and no luck. My events still show up in the events section, but I don't see them on my events page. Help please!

    Thanks

  10. balla4eva33
    Member
    Posted 1 year ago #

    Big note: My page (calendar) is present but empty (no events populate it) until I try to do the migrate process from v4 for the images; that's when the entire page breaks and not even the calendar shows anymore. Thoughts?

  11. balla4eva33
    Member
    Posted 1 year ago #

    Not sure what happened, but apparently waiting overnight cured the problem!? Perhaps it just needed time to fully upgrade? I don't know, but everything seems to be working correctly now! Consider this problem solved!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic