WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
Default date format is set to "d/m/Y", but not for displays (8 posts)

  1. briandavidokeefe
    Member
    Posted 2 years ago #

    Here's an enhancement request: It would be a very nice feature if all the date displays followed whatever the setting is on the "Formats/Layouts" page in the "Date/Time formats" section. The default is "d/m/Y", which I like. But the displays still show events using #j #M #y. It would require less customization if we can just set it in one place and have it carry over to all the other places.

    http://wordpress.org/extend/plugins/events-manager/

  2. briandavidokeefe
    Member
    Posted 2 years ago #

    I forgot to mention: I'm running this with BP 1.5.2, although I don't think it's relevant to this request.

  3. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    Most default formats should be using the new #_EVENTDATES placeholder, but if you upgraded, it wouldn't overwrite your old settings.

  4. briandavidokeefe
    Member
    Posted 2 years ago #

    OK, then I'll have to experiment with this a litte more. I had tried to do a clean install rather than an upgrade, since I only had a couple events at the time. I deleted the old version of EM and put in this new RC. Are those types of display settings actually saved in a database? And if so, is there a documented way for me to remove them so that I have a clean/default slate? I'm afraid that I'll file new "bugs" like this that aren't truly bugs. Thanks.

  5. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    There's a reset button in the settings page, if you do that, it won't delete events, but revert your settings to the default.

    Working on documentation atm.

  6. briandavidokeefe
    Member
    Posted 2 years ago #

    I did the "reset," and it did reset my time and date settings. But there are so many places where dates are displayed differently than the "m/d/Y" setting that I have on the "Formats/Layouts" page in the "Date/Time formats" section, as I originally mentioned. Shouldn't date formats default to using this single setting? Thanks.

  7. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    since we added that placeholder only a few weeks ago, some defaults may not have been changed yet. will get to that asap :)

  8. nikoli
    Member
    Posted 2 years ago #

    +1 this is annoying as hell.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic