WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] Changing booking form (7 posts)

  1. Driekes
    Member
    Posted 2 years ago #

    I am trying to change the appearance of the plugin. At this moment I seem to get it under control, the plugin is very flexible, but complicated to find exactly where you need to edit certain things.

    I am using only single event with one ticket option, so I would like to have the dropdown list for ticket selection next to 'Places'. However for some reason there are <p> tags around: <label for='em_tickets'><?php _e('Spaces', 'dbem') ?></label>

    I am not able to remove them. I asume they are created somewhere in ticket-single.php in combination with wpautop filter. Does anyone have a solution?

    http://wordpress.org/extend/plugins/events-manager/

  2. agelonwl
    Member
    Posted 2 years ago #

  3. Driekes
    Member
    Posted 2 years ago #

    Yes I saw that topic, but in which file should I apply this? The template or the themes functions file? I don't want to disable it for everything!

  4. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    I would avoid making any changes to files and do what you can with CSS

    otherwise you can change booking forms by modifying the templates e.g. templates/placeholders/bookingform.php

  5. Driekes
    Member
    Posted 2 years ago #

    Hi Marcus, I will give it a try. I was already looking into the templates, but I was looking at ticket-single.php. I found the code there, but I could not find the p tags. I've read that wpautop adds these. Can I just disable the filter in the template or doesn't that work?

  6. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    it shouldn't apply to booking forms. maybe this is another plugin you have?

  7. Driekes
    Member
    Posted 2 years ago #

    Hi,

    Thanks for your answers, after a lot of digging I found that my theme was causing this behaviour. My theme removed the wpautop filter and added a custom version for some reason. That is why I could not just disable the filter.

    Thanks for the quick help!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic