WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] Can't reset locations (27 posts)

  1. owcv
    Member
    Posted 2 years ago #

    Since I upgraded to 5.1.5 (and today to 5.1.6), the reset-link in the location-box of an event is gone. So now I'm not able to change or correct locations of an existing event anymore. Can you pls bring it back?

    http://wordpress.org/extend/plugins/events-manager/

  2. agelonwl
    Member
    Posted 2 years ago #

    seems to be working fine on my test site; is it possible to post a sample screenshots?

  3. owcv
    Member
    Posted 2 years ago #

  4. agelonwl
    Member
    Posted 2 years ago #

    hi,

    thanks for the screenshot however can I know what is the installed language?

  5. owcv
    Member
    Posted 2 years ago #

    german

  6. agelonwl
    Member
    Posted 2 years ago #

    Am going to test this out and update you.

  7. agelonwl
    Member
    Posted 2 years ago #

    I tried it using wp @ http://de.wordpress.org/ and EM 5.1.6 fresh install without any other plugin and default theme; seems to be working okay.

    I have these text:

    Erstellen Sie einen Veranstaltungsort, oder fangen Sie an zu einzugeben, um einen zuvor erstellten Veranstaltungsort zu suchen.
    Gespeicherte Veranstaltungsorte können hier nicht bearbeitet werden.<a href="#"> Um einen neuen Veranstaltungsort zu erstellen, setzen sie das Formular zurück.</a>

    can you try to check if the translation files are all updated during your upgrade?

  8. owcv
    Member
    Posted 2 years ago #

    I take a look...

  9. owcv
    Member
    Posted 2 years ago #

    this is strange, I've looked up the source code and found out, that it is hidden:

    <p style="display:none;" id="em-location-reset"><em>Gespeicherte Veranstaltungsorte können hier nicht bearbeitet werden. <a href="#">Um einen neuen Veranstaltungsort zu erstellen, setzen sie das Formular zurück.</a></em></p>

  10. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    this works for me.... maybe it's a JS problem, do you have any errors in your console? (e.g. in google chrome windows, ctrl+shft+J)

  11. owcv
    Member
    Posted 2 years ago #

    No, there is no error in the console.

  12. owcv
    Member
    Posted 2 years ago #

    I also deactivated all my plugins now and had only EM running, but the problem still occurs... :-(

  13. agelonwl
    Member
    Posted 2 years ago #

    that's weird, it's <p style="" id="em-location-reset"> on my test site. can you try to override that css? Am going to check that part again.

  14. owcv
    Member
    Posted 2 years ago #

    I can override it with Firebug, but that's not permanent.

  15. owcv
    Member
    Posted 2 years ago #

    And even if I override it with Firebug and click on the reset link, nothing happens (it only jumps to the top of the page).

    I also found out, that the suggestions for locations entered before are not properly working too; means that there are no suggestions shown anymore. Maybe it has something to do with the no reset possible bug?

    This all happens since I upgraded...

  16. owcv
    Member
    Posted 2 years ago #

    I downgraded a couple of versions and found out, that it works fine again with 5.1.3 (suggestions too). The bug begins with version 5.1.4.

  17. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    chances are it's because you have a javascript conflict. this normally does work.

    have you tried using the default theme and-or disabling other plugins?

  18. owcv
    Member
    Posted 2 years ago #

    Yes I already tried that. I've disabled all plugins except EM and I also changed to default theme. I even tried it on my testing environment. The bug occurs with version 5.1.4. If I use 5.1.3 it works fine! So I assume there must have been changes made that cause this bug.

  19. agelonwl
    Member
    Posted 2 years ago #

    Am going to investigate this more, however if you can try a fresh install wordpress-de using only EM and default theme (local install is okay); there might something that causes the issue.

  20. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    Try the dev version 5.1.6.4 as there's plenty of small fixes there that may help, I think this is JS related.

  21. owcv
    Member
    Posted 2 years ago #

    I tried the new version 5.1.7 but the error still occurs... :-(

  22. agelonwl
    Member
    Posted 2 years ago #

    hi,

    working fine on my site, can you try to look at the template file instead at templates/forms/event/location.php

    to use template - http://wp-events-plugin.com/documentation/using-template-files/

  23. crimay71
    Member
    Posted 2 years ago #

    I'm having the same issue. After updating to WP 3.3.2 and EM 5.1.6 we are no longer able to edit locations from within the Event. It allows us to select a location from a drop down but not edit, which we were able to do before the upgrade. I have deactivated plugins and switched themes and none of this has worked either. This happens whether you are Admin or Editor. Any help would be appreciated. Here's a screen print of the admin: http://prntscr.com/9sx9x

  24. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    not sure what version you updated from, but we stopped allowing that a long while ago. you can only create locations on the event editor, not edit locations.

  25. owcv
    Member
    Posted 2 years ago #

    @ageonwl:

    In line 62 of templates/forms/event/location.php I found the following code:

    <p id="em-location-reset" style="display:none;"><em><?php _e('You cannot edit saved locations here.', 'dbem'); ?> <a href="#"><?php _e('Reset this form to create a location.', 'dbem')?></a></em></p>

    Isn't it the style="display:none;" that prevents the reset-link from being shown?

  26. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    That's normal, provided the JS is working.

    I've discovered a bug where if you disable maps, this stuff stops working. next update should address that, let me know if it helps. btw, enabling maps fixes it.

  27. owcv
    Member
    Posted 2 years ago #

    Indeed! That does the job. Looking forward to the next release. ;-)
    And thanks for the help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic