WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] Can't Add Hyperlinks in WYSIWYG Editor on Submit Event Form (7 posts)

  1. MPSwebdev
    Member
    Posted 1 year ago #

    I have a WP-powered website using the most current update of Events Manager plugin - free version. Very nice plugin, met all our needs.

    However, we ran into some issues with the most recent updates. We first discovered an issue on the submit page with a PHP fatal error of an undefined function call. That was fixed in the most recent update, but now anonymous users cannot submit events at all. We fist noticed this issue when we tried unsuccessfully to add hyperlinks in the WYSIWYG editor when users are not logged in. Currently the settings are set to allow anonymous user events to be submitted. Here are the user's comments: "I was just trying to post an event to our website (without being logged in as an editor) and I noticed that the site rejected any hyperlinks I tried to add to the event’s description. I would click “add link” [from the link dialog box] and a blank event page would reload[erases all user input, instead of adding any links]. I tried changing browsers and that didn’t work. I’m worried readers are unable to add links when they’re adding events to the website. Is there anything we can do?"

    I have looked into support forums to see if this is a problem for anyone else and turned up empty handed. Any help would be appreciated.

    http://wordpress.org/extend/plugins/events-manager/

  2. agelonwl
    Member
    Posted 1 year ago #

    I tried this one and seems to be working okay; do you have a sample link to test and is this using visual editor or html editor?

    Also, have you tried:

    - deactivating other plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems.

  3. MPSwebdev
    Member
    Posted 1 year ago #

    I did test it out on a staging environment and it appeared to work without any of those problems. The submit form is using the visual editor; the WYSIWYG link button reloads the page in error. I deactivated all other plugins and still had this problem, so that isn't it. It seems that we can isolate all the problems down to something that was customized in the plugin settings. I also freshly re-installed the plugin to the current version and anonymous users can now submit again, but the hyperlink issue persists. The thing that is confusing is that the submit form or original event-editor.php file was not edited/changed, so I don't know where to start with the debugging. The only files that are currently custom templates are page-calendar.php and page-events.php . Any pointers on what settings could be causing the hyperlink issue? Thanks!

    Here is a link to the problematic website:
    http://southsoundmag.com/events/submit-event

  4. MPSwebdev
    Member
    Posted 1 year ago #

    It just occurred to me that maybe caching has something to do with the reloading error. We currently use the WP Super Cache plugin to handle high bandwidth. Would caching cause this issue possibly?

  5. agelonwl
    Member
    Posted 1 year ago #

    possible, or try to temporarily switch to default theme to test.

  6. agelonwl
    Member
    Posted 1 year ago #

    also, found this error on your site

    TypeError: jQuery(".flexslider").flexslider is not a function
    http://southsoundmag.com/wp-content/themes/SOSOmag/js/script.js
    Line 34

  7. MPSwebdev
    Member
    Posted 1 year ago #

    that totally did it! thanks. for some reason that piece of javascript was conflicting with the event manager plugin's. fixed it now. thanks so much. all good to go!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic