WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
Bug: Insert category image not working when link url = none (8 posts)

  1. raskull
    Member
    Posted 2 years ago #

    When I choose an image for a category, it does not insert if link url is set to none. It does inisert when link url is set to file url. It seems you should be pulling from file url, not link url, for this to work properly.

    http://wordpress.org/extend/plugins/events-manager/

  2. agelonwl
    Member
    Posted 2 years ago #

    hi, can you give a sample link which doesn't work? is it a local computer link or a link from the wp media library?

  3. raskull
    Member
    Posted 2 years ago #

    This is in admin. When I want to insert a category image, I press the Choose/Upload Image button and get the window. I choose from computer or from media library -- it doesn't matter. If I set Link URL to None then hit Insert into Post, the image is fine (uploads if from computer or takes edits if not) and I am back on the Category screen. However the text input next to the Choose/Upload Image button remains empty, and no image is associated with the category.

    If I want the Link URL to be None, I resort to manually putting in the image path in the text input on the Category screen.

  4. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    maybe you have a plugin/theme conflict, try deactivating your other plugins (and/or try the 2011 theme) and see if it still happens to you.

  5. raskull
    Member
    Posted 2 years ago #

    twenty eleven, no other plugins. It appears you are pulling link url instead of file url, so if link url is left blank there is nothing to pull to the text input for image url on the category admin page. try it.

  6. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    but link URL should not be blank, that's a WP bug then (but it works for most), we don't actually control any aspect of that upload field, it's a WP-handled function/field.

  7. raskull
    Member
    Posted 2 years ago #

    These are the WP options for Link URL: None, File URL, Attachment Post URL.

    Upshot: Select None if you don't want your image to have a Link URL.

    What WP says: The URL/web address to which the image will be linked. Click the File URL button to link the image to its original, full-size version. Click the Post URL button to have the image linked to its attachment page.

    Translation: http://om4.com.au/removing-post-url-wordpress/

    It's not a big deal -- I found a workaround for your implementation -- but if you follow the steps that I outlined above you will see why you would want to populate the text input with File URL instead of Link URL; if the user has selected None in the WP media dialog, your interface fails.

  8. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    I'd consider this more a WP interface bug. The interface is the same for when inserting an image into a post or even a featured image, yet all three are for different things. Here, all you want is the file url because you're uploading an image, nothing else. Resizing etc. would be done later.

    Alternatively, you can just copy/paste your desired page url.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic