WordPress.org

Ready to get started?Download WordPress

Forums

Event Organiser
[resolved] Venues, Categories not showing up on the front end (6 posts)

  1. Alan Laidlaw
    Member
    Posted 1 year ago #

    NOTE: I just posted the same question on the author's site:

    On the admin side, everything works fine. I can attach events to venues and see them in the calendar. However, I can't view the venues on the front end (where taxonomy-event-venue.php is called). I've got the same problem with categories, I can set them but can't see them on the front end.
    This problem seems to have started with 1.5.6. Here are few things I've done to try to debug this:

    - wp-debug:true
    - fresh install, no other plugins
    - reset permalinks (/%postname%/ and /%category%/%postname%/)
    - finally:
    var_dump(get_terms('event-venue',array('hide_empty'=>false))); (your
    advice from the forums)

    That dumped the arrays correctly so I don't understand why they aren't showing up. I'm going to try version 5.5 next. Any help would be really appreciated.

    http://wordpress.org/extend/plugins/event-organiser/

  2. Stephen Harris
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Laidlaw - have you verified that it is a permalink issue? If you go to yoursite.com?event-category=[event-slug], do the categories/events show then? If it is a permalink issue - what is the permalink structure for your events, venue and category 'pages' (set in the plug-in settings)?

    (Side note, if you haven't set 'show past events' to true in the settings, then past events won't appear on the category/venue pages.)

  3. Alan Laidlaw
    Member
    Posted 1 year ago #

    Thanks Steven!
    'show past events' - that solved it! I really appreciate you responding so quickly (and I'm going to blame this on the end of month instead of myself). Big whew!

  4. montytx
    Member
    Posted 1 year ago #

    Hmmm.. I have the exact same issue. This was working fine on my site then stopped. I have enabled and disabled permalinks. I see the same thing with the slug versus the pretty permalinks.

    All I see is what is in the post, no info on the venue and no map. There is a blank space where the map should go and I see all the google map javascript, but no output on the site, just a blank page.

    Here is an example: http://www.planoeastpantherfootball.com/?event=booster-meeting-3

  5. Stephen Harris
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Montytx,

    I can see your venue page at http://www.planoeastpantherfootball.com/?event-venue=plano-east-high-school and I can see events at too http://www.planoeastpantherfootball.com/?post_type=event. (Albeit slightly obscured by the weather). Is it a permalink issue for you?

    Regarding the map not appearing on the event page - you have a javascript error

    maps.gstatic.com/intl/en_gb/mapfiles/api-3/9/16/main.js:29Uncaught TypeError: Cannot read property 'offsetWidth' of null

    Not sure what is causing it - but I don't think its Event Organiser. The map works fine on the venue link above.

  6. montytx
    Member
    Posted 1 year ago #

    Thanks for the Stepehen! I disabled all the plugins and one by one determined it was Simple Facebook Connect causing the issue. Great plug in btw.

    Joel

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic