WordPress.org

Ready to get started?Download WordPress

Forums

Event Organiser
[resolved] Full calendar not browsable and Google Maps doesn't show (5 posts)

  1. guanvanzoggel
    Member
    Posted 2 years ago #

    Hi Stephan,

    Yesterday I moved my properly functioning blog from a subdirectory to root. Since then, I have two problems with Event Organiser (despite being a fresh installation):

    - The [eo_fullcalendar] loads, but isn't browsable. I figure it has something to do with AJAX, but I have no clue how to solve it. I have followed all your suggestions throughout this board.
    - I am unable to add venues in the wp-admin panel, since Google Maps simply doesn't show in the screen where I have to enter the address details.

    The events page is currently located at: http://mearc.eu/events-2/

    Thanks in advance!

    http://wordpress.org/extend/plugins/event-organiser/

  2. Stephen Harris
    Member
    Plugin Author

    Posted 2 years ago #

    Seems like the scripts aren't loading. Did you set the path and url of your wp-content folder in wp-config.php?

    I've justed this on a local install and it worked fine after setting:
    define( 'WP_CONTENT_URL', 'http://localhost/wp-content');
    define( 'WP_CONTENT_DIR', '/var/www/wp-content');

    at the top of the config file (see Codex).

    For getting to set the directory path results in blank page - so I don't think that's the problem. In fact, the plug-in is otherwise working - which suggests the directory path is correct - but that the url is not. So maybe you've not set the content url? That said, you other scripts appear to be loading fine... very odd.

    If that doesn't solve the problem, let me know - it'll be possible to determine where WordPress *thinks* what the url of the scripts are, and from there we can hopefully determine, why it thinks that. But as I've mentioned - this works on a test install.

  3. guanvanzoggel
    Member
    Posted 2 years ago #

    Thank you for your suggestions. However, as you suggested, setting the content url didn't make much of a difference. Upon adding your suggestions, the website returned a blank page.

    With my limited knowledge of coding, can it be the AJAX that is not loading? The jQuery expanding below the full calendar does seem to work properly.

    I'm running WordPress 3.2 by the way. Would that might be the issue?

  4. Stephen Harris
    Member
    Plugin Author

    Posted 2 years ago #

    That would be the issue :). Event Organiser requires 3.3 or higher - partly because it relies on scripts that were only included with WP in 3.3. This is why the plug-in's script aren't loading: the pre-requisite script doesn't exist.

  5. guanvanzoggel
    Member
    Posted 2 years ago #

    Yes, everything seems to be working fine now! Thank you very much for your help, Stephen.

    Looking forward to the Event Organiser Premium/Plus/whatever you are going to call it. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic